Arkusze kalkulacyjne — informacje

Arkusz kalkulacyjny może służyć do wprowadzania i obliczania danych. Arkusz składa się z kolumn i wierszy komórek. Dane można wprowadzać bezpośrednio do komórek arkusza kalkulacyjnego, a następnie wykonywać na nich obliczenia za pomocą formuł. Dane można zmieniać, a wyniki obliczeń będą wyświetlane automatycznie. Dane w arkuszu kalkulacyjnym można również sortować, filtrować i znajdować. Poniższy przykład pokazuje użycie arkusza kalkulacyjnego na stronie sieci Web, która ma służyć jako kalkulator wysokości spłat kredytu hipotecznego. Po zmianie wartości znajdujących się w obramowanych komórkach wejściowych w przeglądarce arkusz kalkulacyjny obliczy ratę spłaty kredytu hipotecznego.

Arkusz kalkulacyjny na stronie sieci Web

Wymagania dotyczące przeglądarki i licencji

Aby wyświetlić arkusz kalkulacyjny w przeglądarce i interakcyjnie z nim pracować, trzeba zainstalować na komputerze składniki Microsoft Office Web Component i przeglądarkę Microsoft Internet Explorer w wersji 4.01 lub nowszej oraz posiadać prawidłową licencję Microsoft Office XP. Bez odpowiedniej licencji można wyświetlać składniki, ale nie można interakcyjnie z nimi pracować. Należy skontaktować się z administratorem sieci lub komputera, aby sprawdzić, czy komputer spełnia odpowiednie wymagania i umożliwia interakcyjną pracę z arkuszami kalkulacyjnymi.

Zapisywanie zmian

Zmiany wprowadzone w arkuszu kalkulacyjnym obowiązują tylko w czasie bieżącej sesji korzystania z przeglądarki. Aby zapisać zmiany wprowadzone w danych znajdujących się w arkuszu kalkulacyjnym, należy je wyeksportować do programu Microsoft Excel i zapisać w tym programie.

Wyłączanie funkcji

Niektóre elementy arkusza kalkulacyjnego znajdującego się na stronie sieci Web mogą być chronione. Na przykład projektant mógł zablokować wybrane komórki, wyłączyć funkcję sortowania i filtrowania albo wyłączyć wyświetlanie paska narzędzi lub okna dialogowego Polecenia i opcje. W przypadku wystąpienia problemów z dostępem do wymienionych funkcji, jeśli komputer spełnia wymagania dotyczące przeglądarki i licencji, należy skontaktować się z projektantem strony sieci Web.


Przeglądarki obsługujące arkusze kalkulacyjne

Aby pracować interakcyjnie z arkuszami kalkulacyjnymi w programie Microsoft Internet Explorer w wersji 4.01 i nowszej, należy zainstalować składniki Microsoft Office Web Component oraz posiadać odpowiednią licencję Office XP. W przypadku braku licencji Office XP można zainstalować wspomniane składniki i przeglądać je na stronie sieci Web, ale nie można interakcyjnie z nimi pracować.

Poniżej przedstawiono poziomy obsługi w przeglądarce, przy założeniu że użytkownik ma składniki sieci Office Web Component oraz licencję Office XP.

Program Microsoft Internet Explorer 5 i nowszy

Użytkownik może korzystać ze wszystkich funkcji arkusza kalkulacyjnego dostępnych z poziomu przeglądarki.

Program Microsoft Internet Explorer 4.01, 4.1x i 4.2x

Użytkownik może korzystać ze wszystkich funkcji arkusza kalkulacyjnego dostępnych z poziomu przeglądarki, z wyjątkiem przypadków, gdy strona sieci Web została utworzona lub zmodyfikowana i zapisana na stronie dostępu do danych w widoku Projekt programu Microsoft Access. Aby uzyskać dostęp do wszystkich funkcji wymagany jest wtedy program Internet Explorer 5.

Inne przeglądarki

We wcześniejszych wersjach programu Microsoft Internet Explorer i w innych przeglądarkach nie można wyświetlać interakcyjnych arkuszy kalkulacyjnych. Arkusz kalkulacyjny pojawia się na stronie stronie sieci Web w postaci pola otoczonego konturem.


Składniki Microsoft Office Web Components — informacje

Składniki Microsoft Office Web Components to zestaw formantów ActiveX instalowanych razem z pakietem Microsoft Office XP. Po zainstalowaniu składników Office Web Components można za pomocą przeglądarki Microsoft Internet Explorer 4.01 lub nowszej interakcyjnie korzystać z arkusza kalkulacyjnego, listy tabeli przestawnej i wykresu na stronie sieci Web. Chcąc używać składników na stronie dostępu do danych w programie Microsoft Access, trzeba zainstalować przeglądarkę Internet Explorer 5 lub nowszą.

Jeśli na komputerze nie zainstalowano składników Office Web Component, ale posiadana jest licencja Office XP, która umożliwia dystrybucję w sieci intranet, to można tak skonfigurować składniki, aby użytkownicy byli monitowani o ich pobranie z firmowej sieci intranet. Pozwala to użytkownikom korzystać ze strony dostępu do danych bez instalacji oprogramowania Office XP na komputerach.

Informacje na temat konfigurowania składników Office Web Components można znaleźć w zestawie Microsoft Office XP Resource Kit.


Tryb tylko do wyświetlania składników Office Web Components — informacje

Jeśli na komputerze nie zainstalowano licencji na oprogramowanie Microsoft Office XP lub nie ma do niej dostępu za pośrednictwem używanej aplikacji pakietu Microsoft Office XP, to składniki Microsoft Office Web Component — Arkusz kalkulacyjny, Wykres lub Tabelę przestawną — można wyświetlać na stronie sieci Web, ale nie można interakcyjnie z nimi pracować.

Aby interakcyjnie pracować z wyświetlonym składnikiem i korzystać z jego wszystkich funkcji, należy zainstalować pakiet Microsoft Office XP lub mieć dostęp do licencji Office XP. Osoby pracujące w środowisku grupowym lub korporacyjnym powinny skontaktować się z administratorem sieci.

W trybie tylko do wyświetlania można:

  • wyświetlać dane,
  • drukować,
  • zaznaczać i przewijać,
  • korzystać z hiperłączy,
  • zmieniać rozmiar składnika,
  • zaznaczać arkusze w składniku Arkusz kalkulacyjny,
  • rozwijać lub zwijać elementy na liście tabeli przestawnej,
  • odświeżać dane na liście tabeli przestawnej,
  • korzystać z poleceń Informacje, Pomoc i Odśwież. Nie są dostępne tematy Pomocy dotyczące funkcji interakcyjnych (takich jak formatowanie komórek, przeciąganie pól, sortowanie, filtrowanie itd.).

W trybie tylko do wyświetlania dostępne są jedynie polecenia Informacje, Pomoc i Odśwież.


Uzyskiwanie pomocy dotyczącej projektowania arkuszy kalkulacyjnych — informacje

Niektóre informacje podane w tym temacie mogą nie mieć zastosowania w przypadku niektórych języków.

Podczas przeglądania i interakcyjnej pracy z arkuszem kalkulacyjnym w przeglądarce sieci Web, użytkownik pracuje ze składnikiem utworzonym w programie nazywanym programem do projektowania. W programie do projektowania, takim jak Microsoft FrontPage lub strony dostępu do danych programu Microsoft Access, można dodawać dane do arkusza kalkulacyjnego, dodać arkusz do zaprojektowanej strony sieci Web i opublikować ją na serwerze sieci Web. Pomoc na temat projektowania arkusza kalkulacyjnego jest dostępna po otwarciu programu do projektowania.

Aby dowiedzieć się więcej o projektowaniu arkusza kalkulacyjnego, najpierw należy wybrać program do projektowania. Można rozpocząć pracę w którymkolwiek z obsługiwanych programów, a następnie kontynuować pracę nad tym samym arkuszem w innym programie, jeśli będą potrzebne dodatkowe opcje i możliwości projektowania.

Uzyskiwanie pomocy w programach do projektowania

Mając licencję Microsoft Office XP i zainstalowane składniki Microsoft Office Web Components, można tworzyć i modyfikować arkusze kalkulacyjne w wielu programach. Można utworzyć arkusz kalkulacyjny w jednym programie, a następnie użyć innego programu do zmodyfikowania arkusza kalkulacyjnego lub strony sieci Web, na której on się znajduje.

Wybór programu do projektowania zależy od ilości pracy związanej z projektowaniem strony sieci Web lub administrowaniem nią, typu używanych danych, a także wiedzy użytkownika o różnych programach do projektowania.

Microsoft Excel Jeśli trzeba wypróbować różne formuły, dostosować odwołania, importować dane z innych źródeł lub zaprojektować interakcyjne wykresy odzwierciedlające dane w arkuszu kalkulacyjnym, to program Excel jest doskonałym środowiskiem projektowym, które może być wykorzystane do tworzenia arkuszy kalkulacyjnych.

Użytkownik może formatować arkusz kalkulacyjny oraz dostosować jego rozmiar i wygląd w innym programie projektowym. W przypadku posiadania programu Microsoft Internet Explorer w wersji 4.01 należy użyć programu Microsoft FrontPage do zmodyfikowania arkuszy kalkulacyjnych publikowanych z programu Excel. Program Excel publikuje arkusze kalkulacyjne jako strony sieci Web z pełną obsługą programu Internet Explorer w wersji 4.01 i nowszej, a program FrontPage zachowuje tę obsługę. Jeżeli strona sieci Web opublikowana z programu Excel jest modyfikowana w widoku Projekt strony dostępu do danych programu Microsoft Access, to konieczne może być zainstalowanie programu Internet Explorer 5 lub nowszego na komputerach użytkowników, aby mogli oni korzystać ze strony sieci Web. Program Excel jest dostępny w pakiecie Microsoft Office XP.

Microsoft FrontPage Jeśli trzeba utworzyć stronę sieci Web lub zmodyfikować arkusze kalkulacyjne publikowane za pomocą programu Excel, to program FrontPage jest zalecanym programem do projektowania. W programie FrontPage można tworzyć arkusze kalkulacyjne na stronach sieci Web, a prócz tego modyfikować arkusze kalkulacyjne projektowane w innych programach. Aby dodać formanty, grafikę, motywy i wiele innych elementów do strony sieci Web, a następnie dodać stronę jako część witryny sieci Web, należy użyć rozbudowanych funkcji administracyjnych i edycyjnych programu Microsoft FrontPage. Program Microsoft FrontPage jest dostępny w pakiecie Microsoft Office XP.

Microsoft Access Jeśli trzeba tworzyć strony sieci Web, w których są wykorzystywane i wyświetlane dane z baz danych, a użytkownicy mają program Internet Explorer 5 lub nowszy, to należy użyć stron dostępu do danych w widoku Projekt programu Access podczas tworzenia arkuszy kalkulacyjnych. Program Access może być wykorzystany do ustanawiania połączeń między bazą danych Access i stroną sieci Web. Następnie można użyć formuł arkusza kalkulacyjnego, aby zwrócić wartości z bazy danych do arkusza kalkulacyjnego. Program Microsoft Access jest dostępny w pakiecie Microsoft Office XP.

Microsoft Visual Basic Jeśli potrzebne jest bardziej zaawansowane środowisko programowania niż środowiska skryptów w programach Excel, FrontPage i Access, to można projektować arkusze kalkulacyjne w języku Visual Basic. Pozwala on dołączyć arkusz kalkulacyjny lub aparat obliczeniowy do niestandardowego rozwiązania. Użytkownicy mogą przeglądać arkusze kalkulacyjne i interakcyjnie z nimi pracować za pomocą formularzy języka Visual Basic w zaprojektowanych programach. Formularz podczas wykonywania staje się samodzielnym środowiskiem, a program pozwala zautomatyzować wiele czynności związanych z arkuszem kalkulacyjnym lub funkcjami obliczeniowymi.

Podczas pracy w programie do projektowania można uzyskać pomoc w następujący sposób:

  • Pomoc programu do projektowania Aby uzyskać informacje dotyczące poleceń i funkcji dostępnych w programie projektowym i przeznaczonych do pracy z arkuszami kalkulacyjnymi, zobacz Pomoc programu projektowego. Na przykład w programie Microsoft FrontPage należy kliknąć Asystenta pakietu Office lub polecenie Microsoft FrontPage — Pomoc [image].

    Program Microsoft Excel zawiera zarówno ogólną Pomoc dotyczącą zapisywania danych programu Excel przeznaczonych do wykorzystania na stronach sieci Web, jak i specyficzne informacje o zapisywaniu arkuszy kalkulacyjnych przeznaczonych do użycia na stronach sieci Web. Aby uzyskać dostęp do Pomocy tego typu w programie Excel, należy kliknąć Asystenta pakietu Office lub polecenie Microsoft Excel — Pomoc [image].

  • Pomoc arkusza kalkulacyjnego w czasie projektowania Jeżeli podczas projektowania dostępne jest okno dialogowe Polecenia i opcje w innym programie projektowym, to dostępne są również tematy pomocy. W uaktywnionym lub utworzonym w programie do projektowania arkuszu kalkulacyjnym należy kliknąć przycisk Pomoc [image] w oknie dialogowym Polecenia i opcje lub przycisk Pomoc na pasku narzędzi arkusza kalkulacyjnego.

Uzyskiwanie pomocy podczas pisania skryptów i programów wykorzystujących arkusze kalkulacyjne

Skrypty i programy mogą być wykorzystane do automatyzowania arkuszy kalkulacyjnych. Można również dołączać arkusze kalkulacyjne do uruchamianych programów, innych niż przeglądarki sieci Web. Programy te można zaprojektować w środowisku programowania takim jak program Microsoft Visual Basic.

Pisanie skryptów Programy pakietu Microsoft Office zawierają Edytora skryptów Microsoft ułatwiającego pisanie skryptów. Na przykład można użyć Edytora skryptów w programie FrontPage, aby dostosować arkusz kalkulacyjny. Aby uzyskać informacje o uruchamianiu Edytora skryptów, zobacz Pomoc programu projektowego pakietu Office. W Edytorze skryptów Microsoft można wyświetlić dodatkową Pomoc dotyczącą wykorzystania jego funkcji i pisania skryptów.

Pomoc modelu obiektowego Aby łatwiej opracowywać program lub skrypt przeznaczony do pracy z arkuszem kalkulacyjnym można wyświetlić informacje dotyczące modelu obiektowego, właściwości i metod specyficznych dla arkusza kalkulacyjnego. Pomoc modelu obiektowego jest instalowana podczas instalowania składników Microsoft Office Web Components, do których należy składnik Arkusz kalkulacyjny. W zależności od wykorzystywanego programu projektowego Pomoc może być wyświetlona w następujący sposób:

  • Pomoc w środowisku Microsoft Visual Basic W języku Visual Basic lub Visual Basic for Applications można utworzyć odwołanie do biblioteki programu Office Web Components. Dzięki temu można uzyskać dostęp do Pomocy poprzez przeglądarkę obiektów lub po zaznaczeniu słowa kluczowego i naciśnięciu klawisza F1. Aby uzyskać informacje o tworzeniu odwołań i używaniu Pomocy modelu obiektów, zobacz Pomoc programu Visual Basic lub Visual Basic for Applications.
  • Pomoc w innych środowiskach Korzystając z innego środowiska projektowania, należy zlokalizować i kliknąć dwukrotnie plik pomocy owcvba10.chm.


Skróty klawiaturowe w arkuszach kalkulacyjnych

Informacje o klawiszach aktywujących i dezaktywujących składnik Arkusz kalkulacyjny pakietu Microsoft Office na stronie sieci Web można znaleźć w Pomocy programu do projektowania.

Klawisze do przenoszenia się i przewijania w arkuszu kalkulacyjnym

Klawisze strzałek
Przenosi o jedną komórkę w górę, w dół, w prawo lub w lewo
CTRL+klawisz strzałki
Przenosi do krawędzi bieżącego regionu danych
HOME
Przenosi do początku wiersza
CTRL+HOME
Przenosi do początku arkusza
CTRL+END
Przenosi do ostatniej komórki w arkuszu, znajdującej się na przecięciu najdalszej, położonej na prawo, używanej kolumny i położonego najniżej używanego wiersza (w prawym-dolnym rogu) lub do komórki leżącej naprzeciwko komórki początkowej, którą zwykle jest A1
PGDN
Przenosi o jeden ekran w dół
PGUP
Przenosi o jeden ekran w górę
ALT+PGDN
Przenosi o jeden ekran w prawo
ALT+PGUP
Przenosi o jeden ekran w lewo
CTRL+PAGE DOWN
Przenosi do następnego arkusza
CTRL+PAGE UP
Przenosi do poprzedniego arkusza
Klawisz TAB
Przenosi do przodu pomiędzy odblokowanymi komórkami w chronionym arkuszu
SHIFT+TAB
Przenosi wstecz między odblokowanymi komórkami w chronionym arkuszu

Klawisze do przemieszczania się przy włączonym klawiszu SCROLL LOCK

SCROLL LOCK
Włącza lub wyłącza tryb SCROLL LOCK
STRZAŁKA W GÓRĘ lub STRZAŁKA W DÓŁ
Przewija ekran o jeden wiersz w górę lub w dół
STRZAŁKA W LEWO lub STRZAŁKA W PRAWO
Przewija o jedną kolumnę w lewo lub w prawo

Klawisze do pracy z arkuszami

SHIFT+F11
Wstawia nowy arkusz
CTRL+PAGE DOWN
Przenosi do następnego arkusza
CTRL+PAGE UP
Przenosi do poprzedniego arkusza

Klawisze do wprowadzania danych w arkuszu

ENTER
Kończy wprowadzanie zawartości do komórki i przenosi w dół w zaznaczeniu
CTRL+ENTER
Wypełnia zaznaczony zakres komórek bieżącym wpisem
SHIFT+ENTER
Kończy wprowadzanie zawartości do komórki i przenosi w górę w zaznaczeniu
Klawisz TAB
Kończy wprowadzanie zawartości do komórki i przenosi w prawo w zaznaczeniu
CTRL+SHIFT+ENTER
Wprowadza formułę tablicową
SHIFT+TAB
Kończy wprowadzanie zawartości do komórki i przenosi w lewo w zaznaczeniu
ESC
Powoduje anulowanie wpisu do komórki
Klawisze strzałek
Przenosi o jeden znak do góry, w dół, w lewo lub w prawo
HOME
Przenosi do początku wiersza
END
Przenosi na koniec wiersza
ALT+0128 (na klawiaturze numerycznej przy włączonym klawiszu Num Lock)
Wprowadza znak waluty euro Symbol waluty euro

Klawisze do pracy z komórkami

F2
Umożliwia edytowanie aktywnej komórki i pozycjonuje punkt wstawiania na końcu zawartości komórki
F9
Powoduje obliczenie wszystkich arkuszy w aktywnym arkuszu kalkulacyjnym
= (znak równości)
Rozpoczyna formułę
ALT+= (znak równości)
Wstawia formułę SUMA za pomocą polecenia Autosumowanie
BACKSPACE
Usuwa znak na lewo od punktu wstawiania lub usuwa zaznaczenie
DELETE
Usuwa znak na prawo od punktu wstawiania lub usuwa zaznaczenie

Klawisze do formatowania danych

CTRL+B
Stosuje lub usuwa pogrubienie
CTRL+I
Stosuje lub usuwa kursywę
CTRL+U
Stosuje lub usuwa podkreślenie

Klawisze do edytowania danych

F2
Umożliwia edytowanie aktywnej komórki i umieszcza punkt wstawiania na końcu wiersza
F4
Przełącza pomiędzy trybem bezwzględnym i względnym dla zaznaczonego aktualnie odwołania
ESC
Powoduje anulowanie wpisu do komórki
BACKSPACE
Powoduje wyczyszczenie aktywnej komórki i pozostawienie w trybie edycji lub usunięcie poprzedniego znaku w aktywnej komórce podczas edytowania zawartości komórki
ENTER
Kończy edytowanie zawartości komórki
CTRL+SHIFT+ENTER
Wprowadza formułę jako formułę tablicową

Klawisze do wstawiania, usuwania i kopiowania zaznaczenia

CTRL+C
Kopiuje zaznaczenie
CTRL+X
Wycina zaznaczenie
CTRL+V
Wkleja zaznaczenie
DELETE
Czyści zawartość zaznaczenia
CTRL+Z
Cofa ostatnią akcję

Klawisze do przenoszenia się obrębie zaznaczenia

ENTER
Przenosi z góry na dół w obrębie zaznaczenia lub przenosi w kierunku wybranym w oknie dialogowym Polecenia i opcje
SHIFT+ENTER
Przenosi z dołu do góry w obrębie zaznaczenia lub przenosi w kierunku przeciwnym do wybranego w oknie dialogowym Polecenia i opcje
Klawisz TAB
Przenosi od lewej do prawej w obrębie zaznaczenia lub przenosi o jedną komórkę w dół, jeśli zaznaczona jest tylko jedna kolumna
SHIFT+TAB
Przenosi od prawej do lewej w obrębie zaznaczenia lub przenosi o jedną komórkę w górę, jeśli zaznaczona jest tylko jedna kolumna

Klawisze do zaznaczania komórek, kolumn lub wierszy

SHIFT+klawisz strzałki
Rozszerza zaznaczenie o jedną komórkę
CTRL+SHIFT+klawisz strzałki
Rozszerza zaznaczenie do ostatniej niepustej komórki w tej samej kolumnie lub tym samym wierszu, w którym jest aktywna komórka
SHIFT+HOME
Rozszerza zaznaczenie do początku wiersza
CTRL+SHIFT+HOME
Rozszerza zaznaczenie do początku arkusza
CTRL+SHIFT+END
Rozszerza zaznaczenie do ostatniej używanej komórki w arkuszu (prawy dolny róg)
CTRL+SPACJA
Zaznacza całą kolumnę
SHIFT+SPACJA
Zaznacza cały wiersz
CTRL+A
Zaznacza cały arkusz
SHIFT+PAGE UP
Rozszerza zaznaczenie o jeden ekran w górę

Klawisze do pracy z listami rozwijanymi Autofiltru

CTRL+T
Włącza autofiltrowanie w zaznaczonym zakresie
ALT+STRZAŁKA W DÓŁ
Otwiera listę rozwijaną Autofiltrowania dla zaznaczonej komórki.
Klawisz TAB
Przenosi kolejno do niedawno wybranego elementu, przycisku OK i przycisku Anuluj na liście rozwijanej Autofiltru
Klawisze strzałek
Przenosi do następnego lub poprzedniego elementu na liście rozwijanej Autofiltru
Klawisze liter i cyfr
Przenoszą do pierwszego elementu rozpoczynającego się od danej litery lub cyfry na liście rozwijanej Autofiltru
SHIFT+ klawisze strzałek
Rozszerza zaznaczenie na liście rozwijanej Autofiltru
SPACJA
Powoduje zaznaczenie lub wyczyszczenie pól wyboru dla wybranych elementów listy rozwijanej Autofiltru
ENTER
Powoduje zamknięcie listy rozwijanej Autofiltru i zastosowanie wprowadzonych zmian
ESC
Powoduje zamknięcie listy rozwijanej Autofiltru bez zastosowania zmian

Klawisze do pracy z Pomocą

Klawisze do pracy w oknie Pomocy

F6
Przełącza między okienkiem nawigacji i okienkiem tematu
ALT+O
Wyświetla menu Opcje, aby udostępnić każde polecenie na pasku narzędzi Pomoc
ALT+SPACJA
Wyświetla menu Sterowanie programu
ALT+F4
Zamyka okno Pomocy

Klawisze do pracy w okienku nawigacji

CTRL+TAB
Przełącza do innej karty
ENTER
Otwiera lub zamyka zaznaczoną książkę albo otwiera zaznaczony temat Pomocy
STRZAŁKA W DÓŁ
Zaznacza następną książkę lub temat Pomocy
STRZAŁKA W GÓRĘ
Zaznacza poprzednią książkę lub temat Pomocy
SHIFT+F10
Wyświetla menu skrótów

Klawisze do pracy w okienku tematu

ALT+STRZAŁKA W PRAWO
Przechodzi dalej do poprzednio przeglądanego tematu Pomocy
ALT+STRZAŁKA W LEWO
Przechodzi wstecz do poprzednio przeglądanego tematu Pomocy
Klawisz TAB
Zaznacza następny tekst ukryty lub hiperłącze albo przycisk Pokaż wszystko lub Ukryj wszystko na początku tematu
SHIFT+TAB
Zaznacza poprzedni tekst ukryty lub hiperłącze
ENTER
Powoduje wykonanie akcji zaznaczonego przycisku Pokaż wszystko, Ukryj wszystko, tekstu ukrytego lub hiperłącza
STRZAŁKA W GÓRĘ albo STRZAŁKA W DÓŁ
Przewija w kierunku początku albo końca tematu Pomocy
PGUP lub PGDN
Przewija w kierunku początku albo końca tematu Pomocy w większych przyrostach
HOME albo END
Przechodzi do początku albo końca tematu Pomocy
CTRL+P
Drukuje bieżący temat Pomocy
CTRL+A
Zaznacza cały temat Pomocy
CTRL+C
Kopiuje zaznaczenie do Schowka
SHIFT+F10
Wyświetla menu skrótów


Narzędzia, polecenia i opcje arkusza kalkulacyjnego — informacje

Pasek narzędzi

Pasek narzędzi w górnej części arkusza kalkulacyjnego umożliwia dostęp do zestawu poleceń, które służą do pracy z danymi arkusza. Aby zobaczyć nazwę polecenia odpowiadającego przyciskowi, należy przytrzymać wskaźnik myszy na przycisku. Jeśli pasek narzędzi jest niewidoczny albo nie można go wyświetlić, projektant strony sieci Web mógł go wyłączyć.

Okno dialogowe Polecenia i opcje

Okno dialogowe Polecenia i opcje zawiera polecenia umożliwiające wyszukiwanie danych w arkuszu kalkulacyjnym, takie jak polecenie Znajdź następny, oraz właściwości określane przez użytkownika, takie jak kolor tła komórek i szerokość kolumn. To okno dialogowe zawiera także polecenia, które są niedostępne na pasku narzędzi lub w menu skrótów. Aby wyświetlić okno dialogowe, należy kliknąć przycisk Polecenia i opcje [image] na pasku narzędzi.

Polecenia i właściwości w oknie dialogowym Polecenia i opcje umieszczone są na kilku kartach, takich jak Formuła, gdzie można zobaczyć formułę z zaznaczonej komórki lub zdefiniować nazwy stosowane w formułach, oraz Format, gdzie może ustawiać formaty liczb, zmieniać kolor tekstu, wybierać style obramowania itd.

Jeśli nie można wyświetlić okna dialogowego Polecenia i opcje, projektant strony sieci Web mógł je wyłączyć.


Wyświetlanie lub ukrywanie paska narzędzi arkusza kalkulacyjnego

  1. Kliknij prawym przyciskiem myszy komórkę w arkuszu kalkulacyjnym, kliknij polecenie Polecenia i opcje w menu skrótów, a następnie kliknij kartę Skoroszyt.
  2. W obszarze Pokazywanie/Ukrywanie zaznacz albo wyczyść pole wyboru Pasek narzędzi.


Pokazywanie lub ukrywanie okna dialogowego Polecenia i opcje

Wykonaj jedną z następujących czynności:
  • Aby wyświetlić okno dialogowe Polecenia i opcje, kliknij przycisk Polecenia i opcje [image] na pasku narzędzi arkusza kalkulacyjnego.
  • Aby ukryć okno dialogowe Polecenia i opcje, kliknij przycisk Zamknij [image] w prawym górnym rogu okna dialogowego.


Dodawanie lub usuwanie arkuszy

  1. Kliknij przycisk Polecenia i opcje [image] na pasku narzędzi arkusza kalkulacyjnego, a następnie kliknij kartę Skoroszyt.
  2. W obszarze Arkusze wykonaj jedną z następujących czynności:
    • Aby dodać arkusz, kliknij przycisk Wstaw. Powtórz tę czynność, aby dodać wiele arkuszy.

      Można zmienić nazwę wstawionego arkusza, zaznaczając nazwę na liście Nazwa arkusza, wpisując nową nazwę w polu Nazwa arkusza, a następnie naciskając klawisz ENTER.

    • Aby usunąć arkusz, kliknij jego nazwę na liście Nazwa arkusza, a następnie kliknij przycisk Usuń.

      Arkusz i jego dane zostaną trwale usunięte.


Zmienianie nazwy arkusza

  1. Na pasku narzędzi arkusza kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Skoroszyt.
  2. W obszarze Arkusze na liście Nazwa arkusza kliknij nazwę arkusza, którą chcesz zmienić.
  3. Wpisz nową nazwę w polu Nazwa arkusza.
  4. Naciśnij klawisz ENTER.


Zmiana kolejności arkuszy

  1. Na pasku narzędzi arkusza kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Skoroszyt.
  2. W obszarze Arkusze na liście Nazwa arkusza kliknij nazwę arkusza, który chcesz przenieść.
  3. Obok pozycji Kolejność kliknij przycisk W górę [image], aby przenieść arkusz w stronę początku skoroszytu, lub przycisk W dół [image], aby przenieść arkusz w stronę końca skoroszytu.


Wyświetlanie lub ukrywanie nagłówków kolumn lub nagłówków wierszy

Nagłówki kolumn to litery w komórkach o kolorze szarym (lub innym, w zależności od ustawień ekranu systemu Microsoft Windows), znajdujących się u góry arkusza kalkulacyjnego, a nagłówki wierszy to liczby w komórkach o kolorze szarym, biegnących z boku arkusza kalkulacyjnego.

  1. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Arkusz.
  2. W obszarze Pokazywanie/Ukrywanie zaznacz albo wyczyść pola wyboru Nagłówki kolumn lub Nagłówki wierszy.


Wyświetlanie lub ukrywanie linii siatki w arkuszu kalkulacyjnym

  1. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Arkusz.
  2. W obszarze Pokazywanie/Ukrywanie zaznacz albo wyczyść pole wyboru Linie siatki.


Wyświetlanie lub ukrywanie selektora arkuszy

Selektor arkuszy składa się z karty Nazwa arkusza i listy Arkusz, przy czym ta ostatnia pojawia się po kliknięciu strzałki na karcie.

  1. Na pasku narzędzi arkusza kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Skoroszyt.
  2. W obszarze Pokazywanie/Ukrywanie zaznacz albo wyczyść pole wyboru Selektor arkuszy.


Zapisywanie zmian

Zmiany wprowadzone do arkusza kalkulacyjnego w przeglądarce są dostępne jedynie podczas bieżącej sesji przeglądarki. Aby zapisać zmiany danych, należy wykonać jedną z następujących czynności:

  • Na pasku narzędzi arkusza kalkulacyjnego kliknij przycisk Eksportuj do programu Microsoft Excel Eksportuj do programu Microsoft Excel i zapisz kopię arkusza kalkulacyjnego jako arkusz programu Microsoft Excel.
  • Skopiuj dane arkusza kalkulacyjnego do programu Excel lub do innego programu na swoim komputerze, a następnie zapisz dane w tym programie.


Cofanie zmian

  • Aby cofnąć ostatnią zmianę wprowadzoną w arkuszu kalkulacyjnym, kliknij przycisk Cofnij [image] na pasku narzędzi. Można cofnąć większą liczbę zmian (do 16), klikając przycisk Cofnij [image] więcej niż raz.
  • Zmiany dokonane w przeglądarce nie są zapisywane. Aby cofnąć wszystkie zmiany dokonane podczas bieżącej sesji, odśwież zawartość wyświetlanej strony sieci Web, klikając przycisk Odśwież [image] na pasku narzędzi przeglądarki.


Drukowanie arkusza kalkulacyjnego

Aby wydrukować arkusz kalkulacyjny z przeglądarki, trzeba wydrukować całą stronę sieci Web.

  • W programie Microsoft Internet Explorer kliknij polecenie Drukuj w menu Plik.

Uwaga Jeśli arkusz kalkulacyjny jest szerszy lub dłuższy od drukowanej strony, to obszary niemieszczące się na stronie nie zostaną wydrukowane. Aby lepiej kontrolować sposób drukowania danych oraz mieć możliwość drukowania długich list i ustawiania podziałów stron, można wyeksportować arkusz kalkulacyjny do programu Microsoft Excel, klikając przycisk Eksportuj do programu Excel Eksportuj do programu Excel na pasku narzędzi. Informację na temat drukowania z programu Excel, można znaleźć w Pomocy programu Excel.


Wprowadzanie tekstu, liczb, dat i godzin w arkuszu kalkulacyjnym — informacje

Niektóre informacje podane w tym temacie mogą nie mieć zastosowania w przypadku niektórych języków.

Wprowadzanie tekstu

Znaki traktowane jako tekst W wypadku arkusza kalkulacyjnego za tekst uważana jest dowolna kombinacja liczb, spacji i znaków nienumerycznych — na przykład arkusz kalkulacyjny traktuje następujące wpisy jako tekst:

10AA109, 127AXY, 12-976, 208 4675.

Wprowadzanie liczb i dat jako tekstu Aby wprowadzać liczby i daty w taki sposób, żeby były traktowane jak tekst, należy poprzedzić je znakiem apostrofu ('). Na przykład, aby wprowadzić numer artykułu 02-01-23 jako tekst, a nie datę, należy wpisać '02-01-23.

Wyrównywanie tekstu Domyślnie tekst w komórce jest wyrównywany do lewej strony. Użytkownik może zmienić sposób wyrównania na wyśrodkowany lub wyrównany do prawej.

Nie można zawijać tekstu w komórkach Nie można wyświetlić kilku wierszy tekstu w pojedynczej komórce.

Powtarzanie tekstu Aby wprowadzić ten sam łańcuch tekstowy w kilku komórkach, należy je zaznaczyć, wpisać odpowiedni tekst, a następnie nacisnąć klawisze CTRL+ENTER.

Znak Euro Aby wprowadzić symbol waluty Euro ( [image] ), należy upewnić się, że klawisz NUM LOCK jest włączony, a następnie wpisać ALT+0128 na klawiaturze numerycznej. W razie korzystania z systemu Microsoft Windows NT 4.0 z dodatkiem Service Pack 3 lub starszym może być konieczne zainstalowanie odpowiedniej aktualizacji z witryny firmy Microsoft w sieci Web. Aby uzyskać informacje dotyczące łączenia się z witryną firmy Microsoft, zapoznaj się z Pomocą odpowiedniego programu. Poniżej przedstawiono czcionki, które umożliwiają wyświetlenie symbolu waluty euro.

System operacyjny | Czcionki
Microsoft Windows 2000 | Arial, Courier New, Tahoma (zwykła i pogrubiona), Times New Roman
Microsoft Windows 98 | Arial, Courier New, Tahoma (zwykła i pogrubiona), Times New Roman
Microsoft Windows NT 4.0 z dodatkiem Service Pack 3 lub starszym i aktualizacją euro | Arial, Courier New, Times New Roman
Microsoft Windows NT 4.0 z dodatkiem Service Pack 4 | Arial, Courier New, Lucida Console, Lucida Sans Unicode, Times New Roman

Wprowadzanie liczb

Znaki, które mogą być użyte jako liczby W arkuszu kalkulacyjnym liczba może zawierać tylko następujące znaki:

0 1 2 3 4 5 6 7 8 9 + – ( ) , / $ % . E e

Arkusz kalkulacyjny ignoruje początkowe znaki plus (+) i traktuje pojedyncze kropki w ciągach numerycznych tak jak w liczbach dziesiętnych. Wszystkie inne ciągi zawierające liczby i znaki nienumeryczne są traktowane jako tekst.

Wprowadzanie ułamków Aby uniknąć uznania wprowadzanego ułamka za datę, należy poprzedzić go cyfrą 0 (zero) i spacją; można na przykład wpisać 0 1/2.

Wprowadzanie liczb ujemnych Liczby ujemne należy poprzedzać znakiem minusa (–)lub ujmować je w nawias ( ).

Wyrównywanie liczb Domyślnie wszystkie liczby wyrównywane są w komórkach do prawej. Użytkownik może zmienić sposób wyrównania na wyśrodkowany lub wyrównany do lewej.

Sposób wyświetlania liczb Sposób wyświetlania liczb zależy od formatu liczby zastosowanego do danej komórki. Jeżeli użytkownik wpisze liczbę w komórce w ogólnym formacie liczby, arkusz kalkulacyjny może zastosować inny format liczby. Na przykład wpisanie wartości 14,73 zł spowoduje, że do takiej komórki zostanie zastosowany format walutowy. Istnieje możliwość zmodyfikowania formatu liczby.

Ogólny format liczby W komórkach w formacie ogólnym wartości liczbowe wyświetlane są jako liczby całkowite (789), ułamki dziesiętne (7,89) albo z użyciem zapisu naukowego (7,89E+08). Zapis naukowy zostaje zastosowany automatycznie, jeśli liczba jest dłuższa niż szerokość komórki. Ogólny format liczby wyświetla maksymalnie 11 cyfr, łącznie z punktem dziesiętnym i znakami takimi jak "E" i "+". Aby korzystać z liczb zawierających więcej niż 11 cyfr, użytkownik może zastosować naukowy format liczby (zapis wykładniczy).

Limit 15-cyfrowy Niezależnie od tego, ile cyfr jest wyświetlanych, w arkuszu można przechowywać liczby wyrażone z dokładnością do 15 cyfr. Jeśli liczba zawiera więcej niż 15 cyfr znaczących, arkusz zmienia liczby nie mieszczące się w limicie na zera (0).

Ustawienia regionalne Znaki rozpoznawane jako liczby zależą od opcji wybranych w ustawieniach regionalnych w Panelu sterowania systemu Microsoft Windows. Wybrane opcje określają również domyślny format liczby na przykład kropkę (.) stosuje się jako symbol dziesiętny w systemach opartych na języku angielskim (USA).

Powtarzanie danych Aby wprowadzić te same dane w kilku komórkach, należy zaznaczyć odpowiednie komórki, wpisać dane, a następnie nacisnąć klawisze CTRL+ENTER.

Wprowadzanie dat i czasu

Daty i wartości czasu są liczbami Arkusz traktuje daty i określenia czasu jak liczby. Sposób wyświetlania daty lub czasu zależy od formatu liczby zastosowanego w komórce. Po wpisaniu daty lub czasu, które arkusz rozpoznaje, format komórki zmienia się z Ogólnego formatu liczby na format daty lub czasu. Domyślnie daty i godziny są w komórce wyrównywane do prawej. Jeżeli arkusz kalkulacyjny nie może rozpoznać formatu daty lub czasu, data lub godzina jest wprowadzana jako tekst, który jest wyrównany do lewej w komórce.

Panel sterowania Opcje wybrane w ustawieniach regionalnych w Panelu sterowania systemu Microsoft Windows określają domyślny format wyświetlania bieżącej daty i czasu. Odnosi się to również do znaków, które rozpoznawane są jako separatory daty i czasu, takich jak na przykład kreska ułamkowa (/) i łącznik () w przypadku daty i dwukropek (:) w przypadku czasu w systemach opartych na języku angielskim (USA).

Korzystanie z czterocyfrowego zapisu lat Interpretując niejednoznaczne zapisy daty, arkusz odwołuje się do pewnych założeń. Na przykład, jeśli wprowadzona zostanie data zawierająca jedynie nazwę miesiąca i jedną lub dwie cyfry, to liczba od 1 do 31 zostanie uznana za numer dnia, a bieżący rok zostanie uznany za rok tej daty. Zapis typu "grudzień 01" zostanie na przykład uznany za 1 grudnia bieżącego roku, a nie grudzień roku 2001. "Grudzień 32" zostanie potraktowany jako 1 grudnia 1932. "12/1/30" to 1 grudnia 1930, ale "12/1/29" to 1 grudnia 2029 (o ile administrator systemu nie zmodyfikował domyślnych ustawień skróconego formatu daty).

Aby mieć pewność, że daty są rozpoznawane przez arkusz w sposób zamierzony przez użytkownika, należy zawsze posługiwać się czterocyfrowym zapisem roku.

Wprowadzanie daty razem z czasem Aby wprowadzić datę i czas w tej samej komórce, należy umieścić pomiędzy nimi spację na przykład "7/10/1976 23:12".

Wprowadzanie czasu przy użyciu symboli AM lub PM Aby wprowadzić wartość czasu opartą na zegarze 12-godzinnym, należy umieścić za nią spację, a następnie wpisać "AM" lub "PM" można na przykład wpisać 9:00 , a następnie AM lub PM.

Wyświetlanie liczby kolejnej kryjącej się za datą lub czasem Niezależnie od tego, jaki format zastosowano do wyświetlenia daty lub czasu, arkusz przechowuje wszystkie daty jako liczby kolejne, a wartości czasu jako ułamki dziesiętne. Aby wyświetlić datę jako liczbę kolejną lub wyświetlić godzinę jako ułamek, należy zaznaczyć komórki zawierające datę lub godzinę i zmienić format liczby na ogólny. W tym formacie fragment numeru reprezentujący datę znajduje się po lewej stronie przecinka dziesiętnego, a fragment reprezentujący godzinę po prawej. Liczba kolejna daty 1 odpowiada w arkuszu niedzieli, 31 grudnia 1899.

Data i czas w obliczeniach Daty i wartości czasu można dodawać i odejmować, a także stosować w innego rodzaju obliczeniach. Aby użyć daty lub godziny w formule, należy wprowadzić datę lub godzinę jako tekst umieszczony w znakach cudzysłowu. Na przykład wynikiem następującego wyrażenia jest 68:

="5/12/2004"-"3/5/2004"


Wprowadzanie tekstu, liczb, dat i godzin w arkuszu kalkulacyjnym

  1. Kliknij komórkę, do której chcesz wprowadzić dane.
  2. Wpisz dane i naciśnij klawisz ENTER lub TAB.

Uwagi

  • Do oddzielenia poszczególnych części daty użyj kreski ułamkowej lub łącznika, na przykład wpisz 5/9/2002 lub 5-wrz-2002.

  • Aby wprowadzić datę według zegara 12-godzinnego, wpisz spację i AM lub PM po wpisaniu czasu, na przykład 9:00 PM. W przeciwnym wypadku arkusz kalkulacyjny zinterpretuje godzinę jako AM.

  • Poprzedź formułę znakiem równości (=).

  • Aby wprowadzić hiperłącze, wpisz adres URL, zaczynając od protokołu takiego jak http:// lub ftp://, a następnie naciśnij klawisz ENTER.

  • Aby wprowadzić te same dane do wielu komórek, zaznacz komórki, wpisz dane, a następnie naciśnij klawisze CTRL+ENTER.


Jak arkusz kalkulacyjny obsługuje daty dotyczące roku 2000 i późniejsze

Z uwagi na skomplikowane zasady interpretowania dat przez programy obliczeniowe, należy zawsze wprowadzać datę w tak precyzyjny sposób, jak to możliwe. Pozwoli to osiągnąć najwyższy poziom dokładności w obliczeniach dat.

Sposób interpretowania niejednoznacznych dat w arkuszu kalkulacyjnym Interpretując niejednoznaczne daty, arkusz kalkulacyjny przyjmuje pewne założenia. Na przykład po wprowadzeniu daty zawierającej tylko nazwę miesiąca i jedną lub dwie cyfry, arkusz kalkulacyjny przyjmuje, że cyfry od 1 do 31 oznaczają dzień, a jako rok przyjmuje rok bieżący. Na przykład zapis grudzień 01 zostanie zinterpretowany jako pierwszy grudnia bieżącego roku, a nie grudzień roku 2001. Zapis grudzień 32 zostanie zinterpretowany jako pierwszy grudnia 1932 roku.

Sposób interpretowania dwucyfrowych numerów lat przez arkusz kalkulacyjny Wprowadzona dwucyfrowa wartość roku domyślnie jest interpretowana w arkuszu w następujący sposób:

  • Od 00 do 29 Arkusz kalkulacyjny interpretuje wartości dwucyfrowe od 00 do 29 jako lata od 2000 do 2029. Na przykład po wpisaniu daty 05-28-19 arkusz przyjmuje, że jest to data 28 maja 2019 r.
  • Od 30 do 99 Arkusz kalkulacyjny interpretuje wartości dwucyfrowe od 30 do 99 jako lata od 1930 do 1999. Na przykład po wpisaniu daty 05-28-98 arkusz przyjmuje, że jest to data 28 maja 1998 r.

Użycie czterocyfrowego roku Aby zapewnić sposób interpretowania w arkuszu kalkulacyjnym wartości roku zgodnie z zamiarem użytkownika, należy wpisać wartości roku jako liczbę czterocyfrową (na przykład 2001 zamiast 01).

Zmiana sposobu interpretacji numeru roku Administrator systemu może tak dostosować pakiet Microsoft Office, aby sposób interpretacji dat był określany za pomocą różnych zasad. Na przykład administrator może zmienić najmniejszą wartość dwucyfrową, interpretowaną jako data w dwudziestym wieku, z 30 na inną wartość. Administratorzy mogą również tak zmieniać domyślny format daty, aby lata były wyświetlane w formacie czterocyfrowym, a nie dwucyfrowym.

Aby ustalić, czy w danym systemie używana jest niestandardowa interpretacja daty, należy skontaktować się z administratorem systemu. Aby uzyskać więcej informacji dotyczących dostosowywania interpretacji daty, należy zapoznać się z zestawem Microsoft Office XP Resource Kit.


Zmienianie danych w komórce

  1. Kliknij komórkę, którą chcesz zmienić.
  2. Wykonaj jedną z następujących czynności:

    • Aby wprowadzić nową liczbę lub tekst w komórce, zamieniając bieżącą zawartość komórki, wpisz nową wartość.

    • Aby zmienić część zawartości komórki, kliknij dwukrotnie na komórkę i dokonaj zmian.

  3. Aby zaakceptować zmiany w komórce, naciśnij klawisz ENTER.

Uwaga Komórka może mieć tylko jedną czcionkę i format tekstu.


Przenoszenie i kopiowanie danych — informacje

Podczas kopiowania komórek kopiowana jest cała komórka, łącznie z formułami i ich wynikami oraz formatami komórki. Kopiowane lub przenoszone komórki zastępują wszystkie dane w obszarze, w którym są wklejane.

Wpływ kopiowania i przenoszenia na formuły

Podczas przenoszenia formuły nie zmieniają się odwołania do komórek. Podczas kopiowania formuły nie zmieniają się bezwzględne odwołania do komórek, natomiast względne odwołania do komórek zmieniają się zależnie od położenia wklejonej komórki. Jeśli na przykład skopiowano formułę

=A1+B1

z komórki C1 do komórki D2, która jest przesunięta o jedną kolumnę w prawo i jeden wiersz w dół w stosunku do komórki C1, to odwołania w formule zostaną zaktualizowane, aby odzwierciedlić nowe położenie:

=B2+C2

Wpływ filtrowania na kopiowanie i przenoszenie

Jeśli na obszarze zaznaczonym do skopiowania znajdują się komórki ukryte na skutek filtrowania, to będą skopiowane tylko widoczne komórki. Jeśli obszar, w którym wklejono dane, zawiera wiersze ukryte na skutek filtrowania, to może być konieczne wyłączenie filtrowania w celu wyświetlenia wszystkich skopiowanych komórek. Nie można przenieść danych z zakresu zawierającego przefiltrowane wiersze. Aby przenieść dane, należy najpierw wyłączyć filtrowanie.

Kopiowanie do innych programów

Komórki kopiowane z arkusza kalkulacyjnego są umieszczane w Schowku pakietu Office w formatach arkusza kalkulacyjnego XML, HTML i jako zwykły tekst. Wybierany jest najwłaściwszy format dla aplikacji, do której dane są wklejane. Na przykład do arkusza programu Microsoft Excel XP komórki są wklejane w formacie arkusza kalkulacyjnego XML, co pozwala odtworzyć formaty formuł, wartości i komórek. W dokumencie programu Microsoft Word komórki są wklejane jako tabela w formacie HTML. Zachowywane jest formatowanie komórek i ich wartości, ale nie zachowywane są zawarte w nich formuły. Do Notatnika komórki są wklejane jako zwykły tekst, bez uwzględniania formatowania lub formuł.

Różnice między kopiowaniem w składniku Arkusz kalkulacyjny a kopiowaniem w programie Microsoft Excel

Różnice pomiędzy kopiowaniem i przenoszeniem danych w Arkuszu kalkulacyjnym a kopiowaniem i przenoszenia danych w programie Excel:

Brak wskaźnika kopiowania Komórki skopiowane w arkuszu kalkulacyjnym nie są wyróżnione w programie Excel za pomocą przesuwanego kreskowanego obramowania wskazującego kopiowany obszar.

Brak polecenia Wklej specjalnie Podczas kopiowania komórek w arkuszu kalkulacyjnym można kopiować wartości, formatowanie i formuły. W odróżnieniu od programu Excel nie można wklejać tych elementów niezależnie, zamieniać miejscami wierszy i kolumn podczas wklejania oraz stosować operacji dodawania, odejmowania, mnożenia lub dzielenia.

Podczas wklejania nie można wstawiać komórek Komórki wklejane w arkuszu kalkulacyjnym zawsze zastępują istniejące komórki. W programie Excel można wstawić skopiowane komórki. Aby dodać puste miejsce dla danych kopiowanych lub przenoszonych w arkuszu kalkulacyjnym, przed wklejeniem skopiowanych komórek można wstawić wiersze i kolumny.

Skopiowane dane pozostają w Schowku Podczas kopiowania w arkuszu kalkulacyjnym dane pozostają w Schowku do momentu kopiowania kolejnych danych lub wymazania danych w Schowku. W arkuszu kalkulacyjnym można skopiować dane, następnie wykonać inne operacje, a po ich zakończeniu wkleić dane. Jeśli przed wklejeniem danych w programie Excel zostanie wykonana inna operacja lub naciśnięty klawisz ESC, to zawartość Schowka jest usuwana.

Dane są wycinane natychmiast Podczas przenoszenia danych w arkuszu kalkulacyjnym dane znikają zaraz po wycięciu i mogą być wklejone tylko raz (skopiowane dane mogą być wklejane wielokrotnie). Podczas przenoszenia danych w programie Excel wycięte dane nie są usuwane z oryginalnej lokalizacji do momentu wklejenia i mogą być wklejane wielokrotnie.


Przenoszenie i kopiowanie danych

Przenoszenie lub kopiowanie całych komórek

Podczas kopiowania lub wycinania, a następnie wklejania komórki, jest ona przenoszona lub kopiowana w całości wraz z formułami i ich wynikami oraz z formatem komórki.

Jeśli zaznaczony do skopiowania obszar zawiera komórki ukryte na skutek filtrowania, skopiują się tylko widoczne komórki. Nie można przenieść danych z zakresu zawierającego filtrowane wiersze. Aby przenieść dane, najpierw należy wyłączyć filtrowanie.

  1. Zaznacz komórki, które chcesz przenieść lub skopiować.
  2. Wykonaj jedną z następujących czynności:

    • Aby przenieść komórki, kliknij przycisk Wytnij [image].

    • Aby skopiować komórki, kliknij przycisk Kopiuj [image].

    Uwaga Po wycięciu danych można wkleić je tylko raz, natomiast po skopiowaniu danych można je wklejać wielokrotnie. Aby wkleić dane w kilka miejsc, należy użyć przycisku Kopiuj do skopiowania danych.

  3. Kliknij lewą górną komórkę obszaru, w którym chcesz wkleić komórki.
  4. Kliknij przycisk Wklej [image].

Uwagi

  • Kopiowane lub przenoszone komórki zastępują wszystkie dane w obszarze, do którego są wklejane.
  • Gdy formuła jest przenoszona, odwołania do komórek w formule nie ulegają zmianie. Po skopiowaniu formuły odwołania bezwzględne nie zmieniają się, ale odwołania względne zmieniają się automatycznie.

Przenoszenie lub kopiowanie znaków w obrębie komórki

  1. Kliknij dwukrotnie komórkę zawierającą znaki, które chcesz przenieść lub skopiować.
  2. W komórce zaznacz znaki, które chcesz przenieść lub skopiować.
  3. Wykonaj jedną z następujących czynności:

    • Aby przenieść znaki, kliknij przycisk Wytnij [image].

    • Aby skopiować znaki, kliknij przycisk Kopiuj [image].

  4. W komórce kliknij miejsce, w którym chcesz wkleić znaki.
  5. Kliknij przycisk Wklej [image].
  6. Naciśnij klawisz ENTER.
Uwaga Po przeniesieniu lub skopiowaniu znaków z jednej komórki do drugiej, przyjmą one formatowanie komórki docelowej.


Wstawianie lub usuwanie wierszy lub kolumn

Wstawianie wierszy lub kolumn

  1. Kliknij komórkę w kolumnie znajdującej się po prawej stronie miejsca, w którym chcesz wstawić nową kolumnę, albo w wierszu poniżej miejsca, w którym chcesz wstawić nowy wiersz.

    Aby wstawić większą liczbę wierszy lub kolumn, zaznacz kilka komórek. Na przykład, aby wstawić trzy wiersze, zaznacz trzy komórki w kolumnie.

  2. Prawym przyciskiem myszy kliknij komórkę lub zaznaczenie, wskaż polecenie Wstaw w menu skrótów, a następnie kliknij opcję Wiersze lub Kolumny.

Usuwanie wierszy lub kolumn

  1. Kliknij komórkę w kolumnie lub wierszu, który chcesz usunąć.

    Aby usunąć większą liczbę wierszy lub kolumn, zaznacz kilka komórek. Na przykład, aby usunąć trzy wiersze, zaznacz trzy komórki w kolumnie.

  2. Prawym przyciskiem myszy kliknij komórkę lub zaznaczenie, wskaż polecenie Usuń w menu skrótów, a następnie kliknij opcję Wiersze lub Kolumny.


Wstawianie, zmienianie lub usuwanie hiperłącza

Wstawianie hiperłącza

  1. Kliknij komórkę, w której chcesz wstawić hiperłącze.
  2. Wpisz adres, zaczynając od prawidłowego protokołu, takiego jak http://, a następnie naciśnij klawisz ENTER, aby wstawić ten adres jako hiperłącze. Na przykład wpisz http://przykład.microsoft.com

Uwaga Adres pojawia się jako podkreślony niebieski tekst. Aby wyświetlić tekst hiperłącza inny niż adres, należy użyć funkcji HIPERŁĄCZE arkusza kalkulacyjnego.

Zmiana hiperłącza

  1. Kliknij komórkę obok hiperłącza, a następnie użyj klawiszy strzałek, aby znaleźć się w komórce z hiperłączem.
  2. Naciśnij klawisz F2, aby rozpocząć edycję w komórce.
  3. Wpisz zmiany w adresie hiperłącza lub w formule korzystającej z funkcji HIPERŁĄCZE arkusza kalkulacyjnego.

Uwaga Podczas modyfikowania hiperłącza, które zostało opublikowane z arkusza kalkulacyjnego Microsoft Excel, a wcześniej utworzone przy użyciu okna dialogowego Wstawianie hiperłącza w programie Excel, użytkownik może zmienić wyświetlany tekst hiperłącza, jednak nie może zmienić adresu, do którego prowadzi dane hiperłącze.

Usuwanie hiperłącza

  1. Kliknij komórkę obok hiperłącza, a następnie użyj klawiszy strzałek, aby znaleźć się w komórce z hiperłączem.
  2. Naciśnij klawisz DELETE.


Czyszczenie zawartości komórek

  1. Zaznacz komórki, które chcesz wyczyścić.
  2. Naciśnij klawisz DELETE.

Porada

Wyczyszczenie zawartości komórek powoduje usunięcie wartości i formuł, ale nie usuwa formatowania. Aby usunąć wartości, formuły i formatowanie, zaznacz komórki, a następnie kliknij przycisk Wytnij [image].


Formuły — informacje

Co to jest formuła?

Formuła jest równaniem wykonującym operacje na podstawie danych arkusza kalkulacyjnego lub innych danych. Formuły mogą wykonywać operacje matematyczne, takie jak dodawanie i mnożenie, mogą także łączyć tekst lub porównywać wartości w arkuszu. Poniższa formuła dodaje wartość z komórki A1 do wartości z komórki A2:

=A1+A2

Formuły mogą używać stałych (takich jak wartość liczbowa lub tekstowa), mogą odwoływać się do komórek arkusza kalkulacyjnego lub korzystać z wartości danych na tej samej stronie sieci Web.

Elementy formuły

Formuła w arkuszu kalkulacyjnym zawsze zaczyna się od znaku równości (=). Za znakiem równości znajdują się elementy, które będą uwzględnione w obliczeniach (operandy), oddzielone operatorami obliczeniowymi. Operatory obliczeniowe to symbole określające typ obliczenia — na przykład dodawanie (+), mnożenie (*) i odejmowanie (-) — które ma być zastosowane do elementów formuły.

Obliczanie

Formuły są obliczane od lewej do prawej, począwszy od znaku równości, i zgodnie z określonym porządkiem dla każdego operatora w formule. Na przykład mnożenie wykonywane jest przed dodawaniem.

=5+2*3*4

W poprzedzającym przykładzie pierwsze od lewej mnożenie (2*3) jest wykonywane jako pierwsze i daje w wyniku 6; następnie wykonywane jest kolejne od lewej strony mnożenie (6*4), co daje wynik 24. Na zakończenie wykonywana jest operacja dodawania (5+24), która daje w wyniku 29.

Można kontrolować kolejność obliczania, zmieniając składnię formuły. Na przykład, jeżeli w celu zmiany składni przykładu powyżej zostaną użyte nawiasy, to 5 i 2 zostaną dodane jako pierwsze (5+2), następnie wynik (7) zostanie pomnożony przez 3, a wynik 21 zostanie pomnożony przez 4, co daje wynik 84.

=(5+2)*3*4

Domyślnie obliczanie arkusza następuje automatycznie, co oznacza, że kiedy nastąpi zmiana w komórce, do której formuła się odwołuje, wówczas formuła jest obliczana ponownie. Można jednak wybrać obliczanie ręczne, tak aby następowało ponownie jedynie wtedy, gdy użytkownik sam o tym zadecyduje.

Stałe a odwołania do komórek

Formuła może odwoływać się do wartości stałych i do innych komórek. Komórka zawierająca formułę jest nazywana komórką zależną, gdy jej wartość zależy od wartości w innych komórkach. Na przykład komórka B2 jest komórką zależną, jeżeli zawiera formułę =C2.

Domyślnie zawsze, gdy zmienia się komórka, do której odwołuje się formuła, zależna komórka również się zmienia. Na przykład, jeżeli wartość w jednej z następujących komórek zmienia się, to wynik formuły =B2+C2+D2 również się zmienia.

Dane w arkuszu

Jeżeli zamiast odwołań do komórek używa się wartości stałych (na przykład =30+70+110), to wynik zmienia się jedynie wówczas, gdy zmieni się samą formułę.

Funkcje

Składnik Arkusz kalkulacyjny pakietu Microsoft Office zawiera wiele wstępnie zdefiniowanych czy też wbudowanych formuł, znanych jako funkcje. Funkcje mogą być używane do wykonywania prostych lub złożonych obliczeń. Przykładowo w następującej formule zastosowano funkcję SUMA, aby dodać do siebie określony zakres komórek:

=SUMA(A1:A5)


Przykłady często używanych formuł

Tworzenie sumy na podstawie jednego warunku

Korzystając z funkcji arkusza kalkulacyjnego SUMA.JEŻELI, można utworzyć sumę dla jednego zakresu przy użyciu wartości z innego zakresu. Na przykład dla każdej komórki w zakresie B5:B25, która zawiera wartość "Northwind", następująca formuła oblicza sumę odpowiednich komórek w zakresie F5:F25.

=SUMA.JEŻELI(B5:B25;"Northwind";F5:F25)

Zliczanie wystąpień wartości lub warunku

Funkcja LICZ.JEŻELI podaje, ile razy w zakresie komórek występuje podana wartość — na przykład, ile komórek z zakresu B5:B25 zawiera tekst "Northwind".

=LICZ.JEŻELI(B5:B25;"Northwind")

Obliczanie bieżącego salda

W arkuszu kalkulacyjnym może być utworzony rejestr służący do śledzenia transakcji bankowych. Jako część takiego arkusza można włączyć formułę obliczającą bieżące saldo. W tym przykładzie przyjęto, że komórka F6 zawiera poprzednie saldo, komórka D7 zawiera sumę częściową depozytu z pierwszej transakcji, a komórka E7 zawiera dowolną kwotę pobraną w gotówce.

Aby obliczyć bieżące saldo dla pierwszej transakcji, do komórki F7 należy wprowadzić następującą formułę:

=SUMA(F6;D7;–E7)

Podczas wprowadzania nowych transakcji, należy skopiować tę formułę do komórki bieżącego salda dla każdego nowego depozytu.

Łączenie imion i nazwisk

Użycie znaku & (handlowe "i") jako operatora tekstowego umożliwia połączenie lub złączenie listy imion w jednej kolumnie z listą nazwisk w innej kolumnie za pomocą formuły. W tym przykładzie przyjęto założenie, że komórka D5 zawiera imię, a komórka E5 zawiera nazwisko.

Aby wyświetlić imię i nazwisko w formacie "imię nazwisko" (na przykład "Jan Kowalski"):

=D5&" "&E5

Aby wyświetlić imię i nazwisko w formacie "nazwisko, imię" (na przykład "Kowalski, Jan"):

=E5&", "&D5

Łączenie daty z tekstem

Aby połączyć, czyli złączyć dwie wartości i utworzyć pojedynczą ciągłą wartość tekstową, należy użyć operatora tekstowego & (handlowe "i"). Aby połączyć ciąg tekstowy z liczbą, datą lub godziną przechowywaną w komórce, należy użyć funkcji TEKST arkusza kalkulacyjnego. Na przykład, jeśli komórka G5 zawiera datę płatności 5-cze-2000, można wyświetlić tekst "Data wyciągu: 5-cze-2000" za pomocą następującej formuły:

="Data wyciągu: "&TEKST(G5; "d-mmm-rrrr")

Powiększanie liczby o określony procent

Wartość liczbowa przechowywana w komórce może być zwiększona procentowo. W tym przykładzie założono, że komórka G5 zawiera wartość, która powinna być zwiększona o 5 procent. Należy pomnożyć wartość z komórki G5 przez 1, aby otrzymać wartość wyjściową, a następnie dodać odpowiedni procent, aby formuła zwróciła w wyniku wartość powiększoną o ten procent.

=G5*(1+5%)

Jeżeli liczba oznaczająca procent jest przechowywana w komórce G2, należy użyć formuły:

=G5*(1+$G$2)

Odwołanie do komórki G2 jest odwołaniem bezwzględnym, dlatego formuła może być kopiowana do innych komórek bez zmiany odwołania do komórki G2.


Tworzenie formuły

  1. Kliknij komórkę, w której chcesz dodać formułę.
  2. Wpisz znak równości (=).
  3. Wpisz formułę.
  4. Naciśnij klawisz ENTER.

Porada

Aby automatycznie wstawić sumę zakresu komórek, zaznacz pierwszą pustą komórkę znajdującą się za danymi, poniżej kolumny danych albo po prawej stronie wiersza danych, które chcesz zsumować, kliknij przycisk Autosumowanie Autosumowanie na pasku narzędzi arkusza kalkulacyjnego, a następnie naciśnij klawisz ENTER.


Zmienianie formuły

  1. Kliknij dwukrotnie komórkę zawierającą formułę, którą chcesz zmienić, aby formuła pojawiła się w komórce.

    Jeżeli komórka zawiera hiperłącze, kliknij komórkę obok komórki, którą chcesz zmienić, a następnie użyj klawisza strzałki do zaznaczenia komórki z formułą, którą chcesz zmienić. Następnie naciśnij klawisz F2.

  2. Dokonaj zmian formuły w komórce.
  3. Naciśnij klawisz ENTER.


Jednoczesne wyświetlanie formuły i jej wyniku

  1. Kliknij komórkę zawierającą formułę, którą chcesz wyświetlić.
  2. Na pasku narzędzi arkusza kalkulacyjnego kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Formuła.
  3. Przejrzyj formułę w polu Formuła w komórce aktywnej (odwołanie). Wynik formuły jest wyświetlany w polu Wartość komórki.


Wstawianie sumy zakresu

Można automatycznie wstawić sumę zakresu komórek za pomocą polecenia Autosumowanie.

  1. Kliknij pierwszą pustą komórkę znajdującą się za danymi, poniżej kolumny danych albo po prawej stronie wiersza danych, które chcesz zsumować lub zaznacz zakres w kolumnie, który chcesz zsumować.
  2. Na pasku narzędzi arkusza kalkulacyjnego kliknij przycisk Autosumowanie [image].

    Sugerowana formuła zostanie wyświetlona w zaznaczonej komórce lub w komórce znajdującej się poniżej zaznaczonego zakresu w kolumnie.

  3. Wykonaj jedną z następujących czynności:

    • Aby zaakceptować sugerowaną formułę, naciśnij klawisz ENTER.

    • Aby zmienić sugerowaną formułę, zaznacz zakres, który chcesz sumować i naciśnij klawisz ENTER.


Zmiana sposobu obliczania arkusza kalkulacyjnego

Jeżeli arkusz kalkulacyjny zawiera wiele formuł, obliczenia mogą trwać długo. Aby przyspieszyć pracę, można zmienić tryb obliczeń z automatycznego na ręczny, aby samemu decydować, kiedy arkusz kalkulacyjny ma być ponownie obliczony.

  1. Na pasku narzędzi arkusza kalkulacyjnego kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Skoroszyt.
  2. W obszarze Obliczanie wykonaj jedną z następujących czynności:

    • Aby ponownie obliczać arkusz kalkulacyjny po każdej zmianie wartości, wybierz opcję Automatyczne.

    • Aby obliczać arkusz kalkulacyjny tylko po naciśnięciu klawisza F9 lub kliknięciu przycisku Oblicz, wybierz opcję Ręczne.


Używanie nazw w formułach — informacje

Przegląd

Zdefiniowana nazwa użyta w formule może ułatwić zrozumienie celu formuły. Na przykład, formuła =SUMA(SprzedażWPierwszymKwartale) może być łatwiejsza do rozpoznania niż =SUMA(C20:C30).

Nazwy mogą być stosowane w każdym arkuszu. Jeśli, na przykład, nazwa PlanowanaSprzedaż odwołuje się do zakresu A20:A30 w pierwszym arkuszu, to można jej użyć w dowolnym innym arkuszu, aby się odwołać do zakresu komórek A20:A30 w pierwszym arkuszu.

Nazwy mogą być także używane do reprezentowania formuł lub wartości, które nie zmieniają się (stałych). Na przykład, można użyć nazwy PodatekOdSprzedaży, aby oznaczyć podatek od sprzedaży (np. 6,2 procent) stosowany w transakcjach sprzedaży.

Uwaga Domyślnie w nazwach stosowane są bezwzględne odwołania do komórek.

Zasady

Jakie znaki są dopuszczalne? Pierwszy znak nazwy musi być literą lub podkreśleniem. Pozostałe znaki w nazwie mogą być literami, cyframi, kropkami i podkreśleniami.

Czy nazwy mogą być odwołaniami do komórek? Nazwy nie mogą być takie same, jak odwołanie do komórek, na przykład Z$100 lub W1K1.

Czy można użyć więcej niż jednego wyrazu? Tak, ale spacje są niedopuszczalne. Jako separatorów wyrazów można użyć znaków podkreślenia i kropki — na przykład Pierwszy.Kwartał albo Podatek_od_sprzedaży.

Ile znaków można użyć? Nazwa może zawierać maksymalnie 255 znaków.

Czy w nazwach ważna jest wielkość liter? Nazwy mogą zawierać małe i wielkie litery. Składnik Arkusz kalkulacyjny nie rozróżnia wielkości liter w nazwach. Jeśli, na przykład, utworzono nazwę Sprzedaż, a następnie inną nazwę SPRZEDAŻ w tym samym arkuszu, to druga nazwa zastąpi pierwszą.


Definiowanie nazw komórek, formuł lub stałych

  1. Na pasku narzędzi arkusza kalkulacyjnego kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Formuła.
  2. W obszarze Nazwy wpisz żądaną nazwę w polu Nazwa.

    Aby zdefiniować nazwę, która ma być dostępna tylko na jednym arkuszu (nazwę lokalną), przed nazwą, której chcesz użyć, wpisz nazwę arkusza i wykrzyknik. Na przykład, chcąc nadać komórce nazwę Budżet i udostępnić ją tylko w arkuszu Arkusz2, wpisz w polu Nazwa następujący ciąg:

    Arkusz2!Budżet

  3. W polu Odwołuje się do wpisz = (znak równości), a następnie formułę, stałą albo odwołanie do komórki lub zakresu komórek, który chcesz nazwać. Na przykład, aby nadać nazwę komórkom od A1 do A5 w Arkuszu1, wpisz:

    =Arkusz1!$A$1:$A$5

  4. Kliknij przycisk Definiuj.


Zmiana lub usuwanie zdefiniowanej nazwy

  1. Na pasku narzędzi arkusza kalkulacyjnego kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Formuła.
  2. W obszarze Nazwy, w polu Wszystkie nazwy kliknij nazwę, którą chcesz zmienić lub usunąć.
  3. Wykonaj jedną z następujących czynności:
    • Aby zmienić nazwę, wpisz nową nazwę w polu Nazwa i kliknij przycisk Definiuj. Następnie kliknij oryginalną nazwę w polu Wszystkie nazwy i kliknij przycisk Usuń.
    • Aby zmienić komórkę, formułę lub stałą reprezentowaną przez nazwę, zmień nazwę w polu Odwołuje się do, a następnie kliknij przycisk Definiuj.
    • Aby usunąć nazwę, kliknij przycisk Usuń.


Odwołania do komórek i zakresów — informacje

Omówienie

Odwołanie identyfikuje komórkę lub zakres komórek i stanowi informację dla arkusza kalkulacyjnego, gdzie szukać wartości lub danych, które mają być użyte w formule. Dzięki odwołaniom użytkownik może w pojedynczej formule korzystać z danych znajdujących się w różnych częściach arkusza kalkulacyjnego lub użyć w kilku formułach wartości z pojedynczej komórki arkusza.

Arkusze kalkulacyjne używają stylu odwołań A1, który opisuje kolumny literami (od A do ZZZ, dla 18 278 kolumn) a wiersze numeruje liczbami (od 1 do 262 144).

Aby odwołać się do komórki, należy wpisać literę kolumny, a następnie numer wiersza. Na przykład odwołanie D50 odnosi się do komórki na przecięciu kolumny D i wiersza 50.

Aby odwołać się do zakresu komórek, należy wpisać odwołanie do komórki znajdującej się w lewym górnym narożniku tego zakresu, dwukropek (:), a następnie odwołanie do komórki znajdującej się w prawym dolnym narożniku tego zakresu. Poniżej zamieszczono przykłady odwołań.

Aby odwołać się do | Użyj
Komórki w kolumnie A i w wierszu 10 | A10
Zakresu komórek w kolumnie A i w wierszach od 10 do 20 | A10:A20
Zakresu komórek w wierszu 15 i w kolumnach od B do E | B15:E15
Wszystkich komórek w wierszu 5 | 5:5
Wszystkich komórek w wierszach od 5 do 10 | 5:10
Wszystkich komórek w kolumnie H | H:H
Wszystkich komórek w kolumnach od H do J | H:J
Zakresu komórek w kolumnach od A do E i w wierszach od 10 do 20 | A10:E20

Odwołania względne i bezwzględne

Odwołania względne Podczas tworzenia formuły zawierającej odwołania do komórek lub zakresów odwołania są zazwyczaj oparte na pozycji komórek względem komórki zawierającej formułę. W przykładzie poniżej komórka B6 zawiera formułę =A5. Wartość jest znajdowana o jedną komórkę w lewo i do góry od komórki B6. Jest to znane jako odwołanie względne.

Formuła z odwołaniem względnym

Kiedy kopiowana jest formuła używająca odwołań względnych, odwołania we wklejonej formule automatycznie zmieniają się tak, aby odnosiły się do komórek odpowiednich w stosunku do komórki, w której się znalazły. W poniższym przykładzie formuła w komórce B2, =A1, odwołuje się do komórki znajdującej się powyżej komórki B2, po jej lewej stronie. Po wklejeniu tej formuły do komórki B3 zostanie ona dopasowana na =A2, tak aby odwoływała się do komórki, która znajduje się powyżej komórki B3, po jej lewej stronie.

Skopiowana formuła zawierająca odwołanie względne

Odwołanie bezwzględne Jeżeli odwołanie nie powinno być dostosowane podczas kopiowania formuły do innej komórki, należy zastosować odwołanie bezwzględne. Aby utworzyć odwołanie bezwzględne, należy wpisać znak dolara ($) przed częściami odwołania, które nie powinny ulegać zmianie. Na przykład, aby utworzyć odwołanie bezwzględne do komórki C1 w formule =A5*C1, należy dodać do formuły znaki dolara w następujący sposób:

=A5*$C$1

Odwołania mieszane Można również spowodować, żeby jedynie odwołanie do wiersza lub do kolumny miało charakter bezwzględny. Odwołanie takie znane jest jako odwołanie mieszane. Na przykład, aby skopiować formułę, w której odwołanie do kolumny ma się zmieniać, natomiast odwołanie do wiersza ma pozostać takie samo, należy umieścić znak dolara tylko przed numerem wiersza:

=C$1

Porada

Aby szybko zmienić odwołanie względne na bezwzględne, należy zaznaczyć je w formule i nacisnąć klawisz F4. Każdorazowe naciśnięcie klawisza F4 powoduje, że odwołanie zmienia się z bezwzględnego odwołania do kolumny i bezwzględnego odwołania do wiersza na względne odwołanie do kolumny i bezwzględne odwołanie do wiersza, względne odwołanie do kolumny i wiersza, a następnie z powrotem na bezwzględne odwołanie do kolumny i wiersza.


Obliczenia — informacje

Obliczenia to proces stosowany przez arkusz kalkulacyjny do wykonywania formuł w komórkach, a następnie wyświetlania wyników jako wartości. Formuły są domyślnie obliczane automatycznie, jeżeli wystąpią zmiany w komórkach, do których odwołują się formuły. Użytkownik może jednak zmienić sposób wykonywania obliczeń przez arkusz kalkulacyjny.

Wartości przechowywane a wartości wyświetlane W niektórych przypadkach sposób wyświetlania wartości różni się od tego, w jaki sposób są przechowywane. Na przykład daty i godziny są przechowywane jako liczby kolejne, jednak są zazwyczaj wyświetlane i drukowane w jednym z kilku formatów daty lub czasu. Arkusz korzysta w obliczeniach z przechowywanych liczb kolejnych, co umożliwia określenie liczby dni między dwoma datami.

Format, w jakim wyświetlane są przechowywane wartości, zależy niekiedy od sposobu formatowania wybranego przez użytkownika. Na przykład użytkownik może sformatować komórkę zawierającą liczbę 123456789 tak, aby była wyświetlana jako 1,23E+08, korzystając z formatu naukowego. Użytkownik może również sformatować komórkę zawierającą datę o liczbie kolejnej 36699 tak, aby data była wyświetlana jako "22-06-2000" lub "22-cze-2000". Zmiana sposobu wyświetlania wartości nie powoduje zmiany wartości przechowywanej.

Sposób wyświetlania różnych formatów liczb, walutowych, daty i czasu zależy również od ustawień regionalnych w Panelu sterowania systemu Microsoft Windows. Ustawienia te określają na przykład, czy lata są wyświetlane jako liczby dwucyfrowe czy czterocyfrowe. Aby uzyskać informacje na temat tych formatów, zapoznaj się z Pomocą systemu Windows.


Operatory obliczeniowe — informacje

Operatory określają typy obliczeń, które mają być wykonane na elementach formuły. Składnik Arkusz kalkulacyjny zawiera cztery typy operatorów obliczeniowych: arytmetyczne, porównania, łączenia tekstu i odwołania. Działania odpowiadające operatorom są wykonywane w określonej kolejności.

Typy operatorów

Arytmetyczne

Następujące operatory arytmetyczne umożliwiają wykonywanie podstawowych operacji matematycznych, na przykład dodawania, odejmowania lub mnożenia; łączenie liczb i otrzymywanie wyników numerycznych.

Operator arytmetyczny | Znaczenie | Przykład
+ (znak plus) | Dodawanie | 3+3
– (znak minus) | Odejmowanie Negacja | 3–1 –1
* (gwiazdka) | Mnożenie | 3*3
/ (kreska ułamkowa) | Dzielenie | 3/3
% (znak procent) | Procent | 20%
^ (daszek) | Potęgowanie | 3^2 (to samo co 3*3)

Porównania

Do porównywania dwóch wartości służą następujące operatory porównania. Wynik porównywania dwóch wartości za pomocą tych operatorów jest wartością logiczną, równą PRAWDA albo FAŁSZ.

Operator porównania | Znaczenie | Przykład
= (znak równości) | Równe | A1=B1
> (znak większości) | Większe niż | A1>B1
< (znak mniejszości) | Mniejsze niż | A1<B1
>= (znak większe niż lub równe) | Większe niż lub równe | A1>=B1
<= (znak mniejsze lub równe) | Mniejsze niż lub równe | A1<=B1
<> (znak nierówności) | Nierówne | A1<>B1

Łączenie tekstu

Aby połączyć jeden lub kilka ciągów tekstowych i utworzyć pojedynczy tekst, należy użyć operatora (&).

Operator tekstowy | Znaczenie | Przykład
& (handlowe i) | Łączenie tekstu | Wynikiem "North" & "wind" jest "Northwind"

Odwołania

Aby połączyć zakresy komórek w obliczeniach, należy użyć następujących operatorów odwołania.

Operator odwołania | Znaczenie | Przykład
: (dwukropek) | Operator zakresu, tworzący jedno odwołanie do wszystkich komórek położonych między dwoma odwołaniami, łącznie z tymi odwołaniami | B5:B15
; (średnik) | Operator połączenia łączący wiele odwołań w jedno | SUMA(B5:B15;D5:D15)
(pojedyncza spacja) | Operator części wspólnej, tworzący pojedyncze odwołanie do komórek wspólnej części obu odwołań | SUMA(B5:B15 A7:D7) W tym przykładzie do części wspólnej zakresów należy komórka B7.

Kolejność wykonywania działań odpowiadających operatorom

Jeśli jedna formuła składa się z kilka operatorów, to składnik Arkusz kalkulacyjny wykonuje operacje w kolejności przedstawionej w poniższej tabeli. Jeśli formuła zawiera operatory o tym samym priorytecie — na przykład operatory mnożenia i dzielenia — składnik Arkusz kalkulacyjny wykonuje odpowiadające operatorom działania od lewej do prawej. Aby zmienić kolejność wykonywania operacji, trzeba umieścić w nawiasach tę część formuły, która ma być obliczona jako pierwsza.

Operator | Opis
: (dwukropek) (pojedyncza spacja) ; (średnik) | Operatory odwołania
– | Negacja (tak, jak w -1)
% | Procent
^ | Potęgowanie
* i / | Mnożenie i dzielenie
+ i — | Dodawanie i odejmowanie
& | Łączenie tekstu (łączenie dwóch ciągów tekstowych)
= < > <= >= <> | Porównanie


Tworzenie formuły używającej danych z tej samej strony sieci Web — informacje

Można zwrócić wartość w komórce na podstawie danych znajdujących się na tej samej stronie sieci Web co arkusz kalkulacyjny, używając funkcji HOST składnika arkusz kalkulacyjny. Na przykład, jeśli na stronie jest pole tekstowe o nazwie Pole_tekstowe_1, następująca formuła pobierze wartość z pola tekstowego i wyświetli ją w komórce zawierającej formułę:

=HOST().Pole_tekstowe_1.wartość

Można także tworzyć formuły wykonujące obliczenia na wartościach zwróconych ze strony sieci Web. Na przykład, jeśli pole tekstowe, z którego zwracana jest wartość, zawiera wielkość sprzedaży, a komórka C1 w arkuszu zawiera współczynnik prowizji, to można pomnożyć wartość zwróconą ze strony sieci Web przez wartość z komórki C1:

=$C$1*HOST().Pole_tekstowe_1.wartość

Można także odwoływać się do wartości w innym arkuszu kalkulacyjnym na tej samej stronie sieci Web. Na przykład, jeśli na stronie sieci Web są arkusze o nazwach arkusz1 i arkusz2, wówczas poniższa formuła w arkuszu arkusz1 zwraca wartość z komórki A1 w arkuszu arkusz2:

=HOST().arkusz2.zakres("a1").wartość

Aby uzyskać więcej informacji dotyczących funkcji, formantów i właściwości, z których można korzystać w arkuszu kalkulacyjnym, zapoznaj się z tematami Pomocy dotyczącymi programowania arkuszy kalkulacyjnych


Formuły tablicowe i stałe tablicowe — informacje

Formuła tablicowa może wykonywać wiele obliczeń, a następnie zwracać pojedynczy wynik lub wiele wyników. Formuły tablicowe działają na dwóch lub większej liczbie zbiorów wartości znanych jako argumenty tablicowe. Każdy argument tablicowy musi mieć taką samą liczbę wierszy i kolumn. Formuły tablicowe tworzy się w taki sam sposób, jak inne formuły, z tym że w celu wprowadzenia formuły tablicowej należy nacisnąć klawisze CTRL+SHIFT+ENTER. Podczas edycji formuła tablicowa jest wyświetlana kursywą.

Stałych tablicowych można używać zamiast odwołań, aby uniknąć wprowadzania wartości poszczególnych stałych w różnych komórkach arkusza.

Niektóre z wbudowanych funkcji są formułami tablicowymi i trzeba je wprowadzać jako tablice, aby uzyskać poprawne wyniki.

Korzystanie z formuł tablicowych

Obliczanie pojedynczego wyniku Ten typ formuły tablicowej może uprościć model arkusza kalkulacyjnego, zastępując wiele różnych formuł jedną formułą tablicową.

Na przykład, poniższa formuła tablicowa oblicza wartość całkowitą tablicy cen akcji i udziałów, bez używania wiersza komórek do obliczania i wyświetlania poszczególnych wartości każdej akcji.

Formuła tablicowa dająca pojedynczy wynik

Formuła =SUMA(B2:C2*B3:C3) wprowadzona jako formuła tablicowa pomnoży liczbę udziałów (w komórkach B2 i C2) przez cenę (w komórkach B3 i C3) każdej akcji, a następnie doda do siebie wyniki tych obliczeń.

Obliczanie wielu wyników Niektóre funkcje arkusza zwracają tablice wartości lub wymagają podania tablic wartości jako argumentu. Aby obliczyć wiele wyników za pomocą formuły tablicowej, należy wprowadzić tablicę do zakresu komórek, który ma tę samą liczbę wierszy i kolumn, co argumenty tablicowe.

Na przykład, jeśli podano trzy wielkości sprzedaży (20 234, 21 003 i 10 000 w kolumnie B) w czasie trzech miesięcy (1, 2 i 3 w kolumnie A), to funkcja REGLINW określi wartości liniowe dla tych wielkości sprzedaży. Aby wyświetlić wszystkie wyniki tej formuły, można ją wprowadzić w trzech komórkach w kolumnie C (C1:C3).

Formuła tablicowa dająca wiele wyników

Formuła =REGLINW(B1:B3;A1:A3) wprowadzona jako formuła tablicowa daje trzy oddzielne wyniki (22 196, 17 079 i 11 962, które mogłyby zostać wyświetlone w komórkach C1, C2 i C3) na podstawie trzech podanych wielkości sprzedaży i trzech miesięcy.

Korzystanie ze stałych tablicowych

W zwykłej formule można wprowadzić odwołanie do komórki zawierającej wartość lub samą wartość, która nazywana jest wtedy stałą. W przypadku formuły tablicowej również można wprowadzić odwołanie do tablicy lub tablicę wartości zawartych w komórkach, co nazywane jest stałą tablicową. Formuły tablicowe akceptują stałe w taki sam sposób, jak formuły nietablicowe, ale stałe tablicowe muszą być wprowadzane w określonym formacie.

Stałe tablicowe mogą zawierać liczby, tekst, wartości logiczne PRAWDA i FAŁSZ lub wartości błędów, takie jak #N/D. W tej samej stałej tablicowej mogą występować różne typy wartości — na przykład {1;3;4\PRAWDA;FAŁSZ;PRAWDA}. Liczby w stałych tablicowych mogą być wartościami całkowitymi, ułamkowymi lub mogą być zapisane w notacji naukowej. Tekst musi być ujęty w cudzysłów — na przykład "wtorek".

Stałe tablicowe nie mogą zawierać odwołań do komórek, kolumn lub wierszy o nierównej długości, formuł ani znaków specjalnych, takich jak $ (znak dolara), nawias lub % (procent).

Format stałych tablicowych

Stałe tablicowe są umieszczane w nawiasach klamrowych ( { } ).

Wartości w różnych kolumnach rozdziela się średnikami (;). Na przykład, chcąc przedstawić wartości 10, 20, 30 i 40, należy wprowadzić ciąg {10;20;30;40}. Taka stała tablicowa jest znana jako tablica 1 na 4 i odpowiada odwołaniu do zakresu o jednym wierszu i czterech kolumnach.

Wartości w różnych wierszach rozdziela się za pomocą kresek ułamkowych odwróconych (\). Na przykład, aby przedstawić wartości 10, 20, 30 i 40 w jednym wierszu, a wartości 50, 60, 70 i 80 w następnym wierszu, należy wprowadzić stałą tablicową o rozmiarach 2 na 4: {10;20;30;40\50;60;70;80}.


Tworzenie formuł tablicowych

Obliczanie pojedynczego wyniku

Formuły tablicowej można użyć do wykonania kilku obliczeń w celu uzyskania pojedynczego wyniku. Ten typ formuły może uprościć model arkusza kalkulacyjnego, zastępując kilka różnych formuł pojedynczą formułą tablicową.

  1. Kliknij komórkę, do której chcesz wprowadzić formułę tablicową.
  2. Wpisz formułę tablicową.

    Na przykład, następująca formuła tablicowa służy do obliczania wartości całkowitej tablicy cen udziałów i akcji bez używania wierszy komórek do obliczania i wyświetlania poszczególnych wartości każdej akcji.

    Formuła tablicowa dająca pojedynczy wynik

    Formuła =SUMA(B2:C2*B3:C3) wprowadzona jako formuła tablicowa pomnoży liczbę udziałów (w komórkach B2 i C2) przez cenę (w komórkach B3 i C3) każdej akcji, a następnie doda do siebie wyniki tych obliczeń.

  3. Naciśnij klawisze CTRL+SHIFT+ENTER.

Obliczanie wielu wyników

Niektóre funkcje arkusza kalkulacyjnego zwracają tablice wartości lub wymagają podania tablic wartości jako argumentu. Aby obliczyć wiele wyników za pomocą formuły tablicowej, należy umieścić tablicę w zakresie komórek, który ma tę samą liczbę wierszy i kolumn, co argumenty tablicowe.

  1. Zaznacz zakres komórek, w których chcesz wprowadzić formułę tablicową.
  2. Wpisz formułę tablicową.

    Na przykład, jeśli podano trzy wielkości sprzedaży (20 234, 21 003 i 10 000 w kolumnie B) w czasie trzech miesięcy (1, 2 i 3 w kolumnie A), to funkcja REGLINW określi wartości liniowe tych wielkości sprzedaży. Aby wyświetlić wszystkie wyniki tej formuły, można ją wprowadzić w trzech komórkach w kolumnie C (C1:C3).

    Formuła tablicowa dająca wiele wyników

    Formuła =REGLINW(B1:B3;A1:A3) wprowadzona jako formuła tablicowa daje trzy oddzielne wyniki (22 196, 17 079 i 11 962, które mogłyby zostać wyświetlone w komórkach C1, C2 i C3) na podstawie trzech podanych wielkości sprzedaży i trzech miesięcy.

  3. Naciśnij klawisze CTRL+SHIFT+ENTER.


Edycja formuły tablicowej

Jeśli formuła tablicowa zajmuje wiele komórek, należy tak edytować cały zakres, jakby była to jedna komórka. Nie można zmienić tylko jednego elementu formuły tablicowej.

  1. Zaznacz komórkę zawierającą formułę tablicową lub, jeśli formuła zajmuje wiele komórek, zaznacz zakres zawierający formułę tablicową.

    Jak?

    1. Zaznacz komórkę w tablicy.
    2. Naciśnij klawisze CTRL+/ (klawisz znaku kreski ułamkowej).
  2. Naciśnij klawisz F2.
  3. Wprowadź zmiany w formule tablicowej.
  4. Naciśnij klawisze CTRL+SHIFT+ENTER.


Zaznaczanie zakresu formuły tablicowej

  1. Zaznacz komórkę w tablicy.
  2. Naciśnij klawisze CTRL+/ (klawisz znaku kreski ułamkowej).


Przenoszenie lub kopiowanie formuły tablicowej

  1. Zaznacz cały zakres tablicy.

    Jak?

    1. Zaznacz komórkę w tablicy.
    2. Naciśnij klawisze CTRL+/ (klawisz znaku kreski ułamkowej).

    Kliknij przycisk Wytnij [image] lub przycisk Kopiuj [image] na pasku narzędzi arkusza.

  2. Zaznacz cały zakres docelowy (w przeciwnym razie tablica zostanie wklejona do pojedynczej komórki).
  3. Kliknij przycisk Wklej [image] .


Korzystanie z funkcji — informacje

Funkcje arkusza kalkulacyjnego

Funkcje są wstępnie zdefiniowanymi formułami wykonującymi obliczenia przy użyciu określonych wartości nazywanych argumentami i w konkretnym porządku nazywanym strukturą. Na przykład funkcja SUMA dodaje wartości lub zakresy komórek, a funkcja PMT oblicza spłaty kredytu na podstawie stopy oprocentowania, okresu spłat i kwoty kredytu. Lista dostępnych funkcji arkusza kalkulacyjnego

Argumenty Argumentami mogą być liczby, tekst, wartości logiczne, takie jak PRAWDA lub FAŁSZ, wartości błędów, takie jak #N/D, odwołania do komórek, stałe, formuły lub inne funkcje. Poszczególne argumenty wyznaczone przez użytkownika muszą mieć prawidłową wartość dla danego argumentu.

Struktura Struktura funkcji zaczyna się od nazwy funkcji, po której występuje nawias otwierający, argumenty funkcji oddzielone średnikami i na końcu nawias zamykający. Jeżeli funkcja rozpoczyna formułę, należy wpisać znak równości (=) przed nazwą funkcji.

Funkcje zagnieżdżone

W niektórych przypadkach konieczne może być użycie funkcji jako jednego z argumentów innej funkcji. Na przykład następująca formuła korzysta z funkcji zagnieżdżonej ŚREDNIA i porównuje wynik z wartością 50.

Prawidłowe wartości zwracane Funkcja zagnieżdżona użyta jako argument musi zwracać taki sam typ wartości, jaki wiąże się z danym argumentem. Jeżeli na przykład argument zwraca wartość PRAWDA lub FAŁSZ, to funkcja zagnieżdżona musi zwracać wartość PRAWDA lub FAŁSZ. Jeżeli warunek ten nie jest spełniony, arkusz kalkulacyjny wyświetli wartość błędu #ARG!.


Formatowanie komórek arkusza kalkulacyjnego

  1. Zaznacz komórki, które chcesz formatować.
  2. Na pasku narzędzi arkusza kalkulacyjnego kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Format.
  3. Wykonaj co najmniej jedną z następujących czynności:

    Zmiana czcionki lub rozmiaru tekstu

    • Aby zmienić wygląd tekstu, kliknij przycisk w grupie Format tekstu.

    • Aby zmienić czcionkę lub rozmiar tekstu, kliknij inną czcionkę na liście Czcionka lub inny rozmiar na liście położonej obok.

    Zmiana formatu liczby

    Po zmianie formatu liczby w komórce, zmienia się wartość wyświetlana, ale wartość przechowywana pozostaje niezmieniona. Na przykład, wartością przechowywaną odpowiadającą dacie 2000-6-22 jest kolejna liczba: 36 699. Nie zmienia się ona, nawet jeśli format liczby komórki zostanie zmieniony na Czwartek, 22 czerwca 2000.
    • W obszarze Format tekstu kliknij żądany format na liście Format liczby.

    Dodawanie obramowania wokół komórek

    • W obszarze Format komórki, obok pola Obramowanie, zaznacz żądany kolor, styl, szerokość i opcje położenia obramowania.

    Zmiana koloru tła komórek

    1. W obszarze Format komórki, obok pola Komórka kliknij strzałkę znajdującą się obok przycisku Kolor wypełnienia [image].
    2. Kliknij żądany kolor na palecie kolorów.

    Wyrównywanie danych w komórce

    • Aby wyrównać tekst w poziomie, kliknij przycisk Wyrównaj do lewej Wyrównaj do lewej, Do środka Do środka lub Wyrównaj do prawej [image] w obszarze Format tekstu.
    • Aby wyrównać tekst w pionie, kliknij przycisk Wyrównaj do góry [image], Wyrównaj środki [image] lub Wyrównaj do dołu [image] w obszarze Format tekstu.

    Uwaga Domyślnie tekst jest wyrównywany do lewej, a liczby, daty i godziny do prawej strony komórki.


Formaty liczby

Niektóre informacje podane w tym temacie mogą nie mieć zastosowania w przypadku niektórych języków.

W arkuszu kalkulacyjnym można zmieniać formaty liczb, używając okna dialogowego Polecenia i opcje zarówno w programie projektowym, jak i podczas wyświetlania w przeglądarce. Ustawienia w Panelu sterowania systemu Microsoft Windows również określają sposób wyświetlania formatów liczb, walut, dat i godzin. Na przykład, określają one, czy numer roku ma być wyświetlany jako liczba dwucyfrowa czy czterocyfrowa. Informacje na temat formatów można znaleźć w Pomocy systemu Windows.

W programie Microsoft Visual Basic lub skrypcie można przypisać danym niestandardowe formaty liczb. Można także wpisać niestandardowe formaty dostępne w polu Format liczby modelu obiektowego arkusza kalkulacyjnego. Aby znaleźć więcej informacji, zobacz sposób uzyskiwania pomocy podczas programowania arkusza kalkulacyjnego.

Następujące formaty liczb są dostępne na liście Format liczby, na karcie Format okna dialogowego Polecenia i opcje.

Format | Działanie
Data ogólna | Wyświetla liczbę jako datę z opcjonalną godziną. Na przykład 31/8/99 05:54. Ułamkowa część liczby jest interpretowana jako godzina. Jeżeli liczba nie ma części ułamkowej, to wyświetlana jest wyłącznie data. Jeżeli liczba ma wyłącznie część ułamkową, to wyświetlana jest tylko godzina.
Data długa | Wyświetla datę zgodnie z ustawieniem regionalnym systemu Windows dla formatu daty długiej. Na przykład czwartek, 25 stycznia 2001.
Data średnia | Wyświetla datę zgodnie z ustawieniami regionalnymi miesięcy i separatora daty w systemie Windows, a rok wyświetla w postaci dwucyfrowej. Na przykład 25-sty-01.
Data krótka | Wyświetla datę zgodnie z ustawieniami regionalnymi systemu Windows dla formatu daty krótkiej. Na przykład 25/1/01.
Godzina długa | Wyświetla godzinę zgodnie z ustawieniami regionalnymi systemu Windows dla formatu godziny długiej. Na przykład 20:45:36.
Godzina średnia | Wyświetla godzinę w formacie 12-godzinnym ze znacznikiem AM lub PM z pominięciem sekund. Na przykład 8:45 PM.
Godzina krótka | Wyświetla godzinę w formacie 24-godzinnym, z pominięciem sekund. Na przykład 20:45.
Ogólny | Wyświetla liczbę wyrównaną do prawej bez separatora tysięcy, poprzedzoną znakiem minus, jeżeli liczba jest ujemna. Wyświetla maksymalnie 11 cyfr lub 10 cyfr z przecinkiem dziesiętnym, zaokrąglając dodatkowe cyfry po prawej stronie przecinka dziesiętnego. Wyświetla liczby zawierające więcej niż 11 cyfr po lewej stronie przecinka dziesiętnego w formacie naukowym. Wyświetla tekst wyrównany do lewej.
Waluta | Wyświetla liczbę zgodnie z regionalnymi ustawieniami waluty w systemie Windows, z separatorem tysięcy, jeżeli jest on potrzebny i z dwoma miejscami po przecinku. Na przykład, zgodnie z domyślnymi ustawieniami regionalnymi dla języka polskiego, będzie to 2 532,75 zł.
Waluta euro | Wyświetla liczbę jako walutę euro z separatorem tysięcy i dwoma miejscami po przecinku. Znak euro jest umieszczony przed lub za liczbą, zgodnie z ustawieniami regionalnymi waluty w systemie Windows. Na przykład, zgodnie z domyślnymi ustawieniami regionalnymi dla języka polskiego, będzie to 12,35 [image] .
Stały | Wyświetla liczbę z dwoma miejscami dziesiętnymi. Na przykład 68,30.
Standardowy | Wyświetla liczbę z separatorem tysięcy i dwoma cyframi na prawo od przecinka dziesiętnego. Ustawienia regionalne systemu Windows dla liczb określają symbol używany jako separator tysięcy. Na przykład, jeżeli separatorem tysięcy jest spacja, liczba wygląda następująco 1 800,00.
Procentowy | Wyświetla liczbę pomnożoną przez 100, z dwoma miejscami dziesiętnymi i znakiem procentu. Na przykład, wartość 0,8914 będzie wyświetlana jako 89,14%.
Naukowy | Wyświetla liczbę w notacji wykładniczej. Na przykład 1,25E+10.
Tak/nie | Wyświetla wyraz Nie, jeżeli liczba jest równa 0, a wyraz Tak dla wszystkich innych liczb.
Prawda/fałsz | Wyświetla wyraz Fałsz, jeżeli liczba ma wartość 0, a wyraz Prawda dla wszystkich innych liczb.
Wł/Wył | Wyświetla skrót Wył, jeżeli liczba ma wartość 0, a skrót Wł, jeżeli ma ona inną wartość.


Scalanie lub rozdzielanie komórek

  1. Zaznacz komórki, które chcesz scalić. Pamiętaj, że po scaleniu komórek zachowywane są jedynie dane z komórki w lewym górnym rogu zaznaczonego zakresu. Dane z pozostałych komórek są usuwane.
  2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Format.
  3. W obszarze Format komórki kliknij przycisk Scal komórki [image] lub Rozdziel komórki [image].


Zmiana szerokości kolumny

  1. Upewnij się, że nagłówki kolumn są wyświetlone.

    Jak?

    Nagłówki kolumn to litery w komórkach o kolorze szarym (lub innym, w zależności od ustawień ekranu systemu Microsoft Windows), znajdujących się u góry arkusza kalkulacyjnego, a nagłówki wierszy to liczby w komórkach o kolorze szarym, biegnących z boku arkusza kalkulacyjnego.

    1. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Arkusz.
    2. W obszarze Pokazywanie/Ukrywanie zaznacz albo wyczyść pola wyboru Nagłówki kolumn lub Nagłówki wierszy.
  2. Zaznacz kolumny, które chcesz zmienić.
  3. Wskaż prawą granicę nagłówka kolumny lub zaznaczenia, tak aby wskaźnik zmienił się na Wskaźnik z prostopadłą strzałką z dwoma grotami.

  4. Przeciągnij granicę do osiągnięcia żądanej szerokości lub kliknij dwukrotnie prawą granicę kolumny, aby dopasować szerokość kolumny do zawartości.


Zmiana wysokości wiersza

  1. Upewnij się, że numery wierszy są wyświetlone w arkuszu kalkulacyjnym.

    Jak?

    Nagłówki kolumn to litery w komórkach o kolorze szarym (lub innym, w zależności od ustawień ekranu systemu Microsoft Windows), znajdujących się u góry arkusza kalkulacyjnego, a nagłówki wierszy to liczby w komórkach o kolorze szarym, biegnących z boku arkusza kalkulacyjnego.

    1. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Arkusz.
    2. W obszarze Pokazywanie/Ukrywanie zaznacz albo wyczyść pola wyboru Nagłówki kolumn lub Nagłówki wierszy.
  2. Zaznacz wiersze, które chcesz zmienić.
  3. Wskaż dolną granicę nagłówka wiersza lub zaznaczenia, tak aby wskaźnik zmienił się na Wskaźnik z prostopadłą strzałką z dwoma grotami.

  4. Przeciągnij granicę, aż wiersz lub zaznaczenie osiągnie żądaną wysokość lub kliknij dwukrotnie dolną granicę wiersza, aby dopasować wysokość wiersza do zawartości.


Wyświetlanie tekstu lub arkusza kalkulacyjnego w sposób umożliwiający czytanie od prawej do lewej lub od lewej do prawej

Jeśli arkusz kalkulacyjny będzie przeglądany w językach, w których czyta się od prawej do lewej, to należy korzystać z wyświetlanie lub położenia tekstu od prawej do lewej.

Wyświetlanie całego arkusza kalkulacyjnego w kierunku od prawej do lewej lub od lewej do prawej

  1. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Arkusz.

  2. W obszarze Pokazywanie/Ukrywanie zaznacz lub wyczyść pole wyboru Wyświetl od prawej do lewej.

Po wybraniu wyświetlania od prawej do lewej strony elementy arkusza kalkulacyjnego są pokazywane w postaci lustrzanego odbicia domyślnego wyświetlania od lewej do prawej: numery wierszy są wyświetlane po prawej, a paski przewijania pionowego po lewej stronie arkusza kalkulacyjnego.

Wyświetlanie tekstu w kierunku od prawej do lewej lub od lewej do prawej

Domyślny kierunek wyświetlania tekstu określa Kontekst, czyli tekst jest automatycznie wyświetlany od lewej do prawej lub od prawej do lewej w zależności od używanego języka. Można jednak tak ustawić komórki, aby wyświetlały tekst od prawej do lewej lub od lewej do prawej, co pozwala podczas pracy z różnymi językami w poszczególnych komórkach określać różne kierunki tekstu.

  1. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Format.

  2. W obszarze Format tekstu kliknij strzałkę obok pola Kierunek tekstu, a następnie zaznacz jedną opcję na liście.


Wyszukiwanie danych — informacje

Funkcja Znajdź (okno dialogowe Polecenia i opcje, karta Arkusz) umożliwia wyszukiwanie tekstu, liczb, dat i godzin, które wpisano bezpośrednio do komórek, lub które są wynikami formuł.

Korzystając z opcji związanych z funkcją Znajdź, należy pamiętać o następujących zasadach:

  • Uwzględnij wielkość liter Działanie funkcji Znajdź nie jest domyślnie uzależnione od wielkości liter. Aby wyszukać tylko te komórki, których wartości odpowiadają podanej wielkości liter, należy zaznaczyć pole wyboru Uwzględnij wielkość liter.
  • Tylko całe komórki Domyślnie funkcja Znajdź umożliwia wyszukiwanie komórek, które zawierają wartość podaną w polu Znajdź. Na przykład wpis „Jan” powoduje wyszukiwanie komórek zawierających ciągi takie jak „Janicki” lub „Janko Muzykant”. Aby wyszukać tylko te komórki, które oprócz podanej wartości nie zawierają niczego innego, należy zaznaczyć pole wyboru Tylko całe komórki.
  • Wartości sformatowane Funkcja Znajdź umożliwia wyszukiwanie wyświetlonych wartości, a nie formatów. Rozważmy na przykład sytuację, w której do danej komórki zastosowano format liczby Tak/Nie. Jeśli taka komórka zawiera zero (0), zostanie w niej wyświetlone słowo Nie, i aby wyszukać wystąpienia tego słowa, można użyć funkcji Znajdź. Nie można korzystać z funkcji Znajdź w celu wyszukiwania komórek sformatowanych przy użyciu określonego koloru lub czcionki.
  • Kierunek wyszukiwania Funkcja Znajdź powoduje wyszukiwanie od lewej do prawej strony przez kolejne kolumny pierwszego wiersza, a następnie od lewej do prawej w kolumnach drugiego wiersza itd.
  • Symbole wieloznaczne Funkcja Znajdź nie pozwala na korzystanie z symboli wieloznacznych, takich jak znak zapytania (?) czy gwiazdka (*).
  • Dane ukryte Funkcja Znajdź nie pozwala na wyszukiwanie danych w komórkach ukrytych lub w komórkach, do których zastosowano filtrowanie.


Wyszukiwanie danych

  1. Aby przeszukać cały arkusz, kliknij pojedynczą komórkę; aby przeszukać określony zakres komórek, zaznacz ten zakres.

  2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Arkusz.
  3. W polu Znajdź wpisz tekst lub wartość, którą chcesz wyszukać.

    Uwagi

    • Domyślnie funkcja Znajdź powoduje wyszukiwanie komórek, które zawierają wartość wprowadzoną w polu Znajdź. Na przykład wpis „Jan” powoduje wyszukiwanie komórek zawierających ciągi takie jak „Janicki” lub „Janko Muzykant”. Aby wyszukać tylko te komórki, które oprócz wprowadzonej wartości nie zawierają niczego innego, należy zaznaczyć pole wyboru Tylko całe komórki.
    • Domyślnie funkcja Znajdź nie uwzględnia wielkości liter. Aby wyszukać tylko te komórki, których wartości odpowiadają podanej wielkości liter, należy zaznaczyć pole wyboru Uwzględnij wielkość liter.
  4. Kliknij przycisk Znajdź następny.


Sortowanie danych

Dane, które mają być sortowane, powinny mieć formę listy. Lista ma podobne elementy w każdej kolumnie, ma etykiety kolumn w pierwszym wierszu, licząc od góry, i nie zawiera pustych wierszy ani kolumn.

Sortowanie według pojedynczej kolumny

  1. Aby posortować całą listę, kliknij jedną z zawartych w niej komórek. Sortowanie nie obejmuje etykiet kolumn.

    Aby posortować część listy, zaznaczy odpowiedni zakres. Jeśli nie chcesz sortować etykiet kolumn wraz z pozostałą częścią zakresu, nie uwzględniaj ich w zaznaczeniu.

  2. Kliknij strzałkę obok przycisku Sortuj rosnąco [image] lub Sortuj malejąco [image] na pasku narzędzi arkusza, a następnie kliknij kolumnę, według której chcesz sortować.

Uwagi

  • Wiersze ukryte wskutek filtrowania albo o wysokości ustawionej na wartość zero nie są sortowane.
  • Sortowane mogą być tylko wiersze. Nie można sortować kolejności kolumn.
  • Sortowanie nie uwzględnia wielkich i małych liter. Na przykład przy sortowaniu rosnącym "BIAŁY" i "biały" zostaną umieszczone przed "CZARNY" i "czarny".

Sortowanie według więcej niż jednej kolumny

Aby sortować listę według więcej niż jednej kolumny, posortuj ją kilkakrotnie, za każdym razem według innej kolumny. Następująca lista na przykład została uporządkowana według sprzedawców. Najpierw posortowano ją według kolumny Produkt (kolumnę taką określa się mianem kolumny wewnętrznej lub kolumny niższej kategorii), tak aby produkty zostały ułożone w kolejności alfabetycznej. Następnie posortowano listę według kolumny Sprzedawca (kolumnę tę określa się jako kolumnę zewnętrzną lub kolumnę wyższej kategorii).

Przykład danych sortowanych według dwóch kolumn

  1. Najpierw określ kolejność kategoryzacji. Na przykład, jeśli sortujesz według dwóch kolumn, najpierw określ, która z kolumn jest ważniejsza, a która mniej ważna.

  2. Zaznacz komórkę w kolumnie niższej kategorii (kolumnie wewnętrznej).

  3. Kliknij strzałkę obok przycisku Sortuj rosnąco [image] lub Sortuj malejąco [image] na pasku narzędzi arkusza, a następnie kliknij kolumnę, według której chcesz sortować.

  4. Zaznacz komórkę w kolumnie wyższej kategorii (kolumnie zewnętrznej) i powtórz krok powyżej.

  5. Powtórz te czynności dla każdej kolumny wyższej kategorii, aż skończysz.

Uwagi

  • Wiersze ukryte wskutek filtrowania albo o wysokości ustawionej na wartość zero nie są sortowane.
  • Sortowane mogą być tylko wiersze. Nie można sortować kolejności kolumn.
  • Sortowanie nie uwzględnia wielkich i małych liter. Na przykład przy sortowaniu rosnącym "BIAŁY" i "biały" zostaną umieszczone przed "CZARNY" i "czarny".


Stosowanie lub usuwanie filtru

Stosowanie filtru

  1. Kliknij komórkę na liście, która ma być filtrowana, albo zaznacz określony zakres komórek, który ma być filtrowany.
  2. Na pasku narzędzi kliknij przycisk Autofiltr [image], tak aby był zaznaczony.
  3. Kliknij strzałkę w kolumnie zawierającej dane, które mają być wyświetlone.

  4. Aby wyświetlić tylko żądane elementy, wyczyść pole wyboru Pokaż wszystko, a następnie zaznacz pole wyboru każdego z elementów, który ma być wyświetlony.

Usuwanie filtru

  • Na pasku narzędzi kliknij przycisk Autofiltr [image], tak aby nie był zaznaczony.


Sumowanie filtrowanych danych

  1. Przefiltruj dane, aby wyświetlić wiersze, które chcesz podsumować.

    Jak?

    Stosowanie filtru

    1. Kliknij komórkę na liście, która ma być filtrowana, albo zaznacz określony zakres komórek, który ma być filtrowany.
    2. Na pasku narzędzi kliknij przycisk Autofiltr [image], tak aby był zaznaczony.
    3. Kliknij strzałkę w kolumnie zawierającej dane, które mają być wyświetlone.

    4. Aby wyświetlić tylko żądane elementy, wyczyść pole wyboru Pokaż wszystko, a następnie zaznacz pole wyboru każdego z elementów, który ma być wyświetlony.

    Usuwanie filtru

    • Na pasku narzędzi kliknij przycisk Autofiltr [image], tak aby nie był zaznaczony.

  2. Kliknij komórkę znajdującą się pod danymi, które chcesz podsumować.
  3. Kliknij przycisk Autosumowanie [image] na pasku narzędzi arkusza, a następnie naciśnij klawisz ENTER.

Uwaga Przycisk Autosumowanie powoduje sumowanie danych tylko z widocznych wierszy. Aby włączyć do sumowania wszystkie wiersze, pokaż wszystkie wiersze i wtedy dokonaj sumowania.


Arkusze kalkulacyjne publikowane za pomocą programu Microsoft Excel — informacje

Po opublikowaniu arkusza za pomocą programu Microsoft Excel większość funkcji tego programu zostaje zachowana i działa w taki sam sposób, jak w programie Excel. Funkcje programu Excel wymienione na liście poniżej działają inaczej lub nie są zachowywane podczas publikowania lub zapisywania jako arkusz kalkulacyjny na stronie sieci Web.

Formuły, funkcje i obliczenia w programie Excel | Zdarzenia występujące podczas publikowania lub zapisywania jako strona sieci Web
Etykiety w formułach | Etykiety są konwertowane na odwołania do komórek.
Odwołania do danych w innych arkuszach | Odwołania są konwertowane na wartości.
Sumy częściowe | Liczby i obliczenia są wyświetlane poprawnie. Funkcje grup i konspektu nie są zachowywane.
System daty 1904 | Wyświetlane daty pozostają bez zmian, ale liczby kolejne dla dat są konwertowane na system daty 1900.
Dokładność jak wyświetlono | Wartość komórki jest publikowana.
Styl odwołań W1K1 | Styl odwołań W1K1 jest konwertowany na styl odwołań A1.
Funkcje formatowania, grafiki i wyświetlania w programie Excel | Zdarzenia występujące podczas publikowania lub zapisywania jako strona sieci Web
Tekst obrócony lub pionowy | Tekst obrócony lub pionowy jest konwertowany na tekst w poziomie.
Wyrównanie rozłożone | Niezachowywane.
Wyrównanie tajlandzkie | Niezachowywane.
Wcięty tekst | Niezachowywane.
Zawinięty tekst w komórkach | Niezachowywane.
Grafika | Niezachowywane.
Wypełnienia deseniem | Niezachowywane.
Kropkowane lub przerywane obramowania | Kropkowane lub przerywane obramowania są konwertowane na obramowania ciągłe.
Wiele czcionek w jednej komórce | Niezachowywane. Używana jest czcionka pierwszego znaku z komórki.
Formatowanie warunkowe | Niezachowywane.
Komentarze komórki | Niezachowywane.
Ograniczenia i komunikaty sprawdzania wiarygodności danych | Niezachowywane.
Strzałki śledzenia dla inspekcji | Niezachowywane.
Tworzenie konspektu | Zwinięte wiersze są publikowane jako ukryte. Rozwinięte wiersze są publikowane normalnie.
Funkcje drukowania i ustawienia strony | Niezachowywane.
Funkcje obsługi plików, współużytkowania i importowania w programie Excel | Zdarzenia występujące podczas publikowania lub zapisywania jako strona sieci Web
Współdzielone informacje o skoroszycie | Niezachowywane.
Zgodność z programem Lotus | Styl odwołań W1K1 jest konwertowany na styl odwołań A1.
Zakresy danych zewnętrznych | Wartości są publikowane. Nie jest zachowywana możliwość odświeżania z danych źródłowych.
Kwerendy sieci Web | Wartości są publikowane. Nie jest zachowywana możliwość odświeżania z danych źródłowych.
Hasła | Niezachowywane.


Eksportowanie arkusza kalkulacyjnego do skoroszytu programu Microsoft Excel

  • Na pasku narzędzi arkusza kalkulacyjnego kliknij przycisk Eksportuj do programu Microsoft Excel Eksportuj do programu Microsoft Excel, aby uruchomić program Microsoft Excel lub przełączyć się do niego i wyświetlić dane w skoroszycie.

Uwagi

  • Ponieważ program Microsoft Excel obsługuje 256 kolumn i 65 536 wierszy, dane z kolumn w przedziale od IW do ZZZ oraz z wierszy w przedziale od 65 537 do 262 144 nie zostaną wyeksportowane z arkusza kalkulacyjnego. Można jednak skopiować te dane do większej liczby skoroszytów programu Microsoft Excel.
  • Podczas eksportowania danych z arkusza kalkulacyjnego do programu Excel eksportowane są tylko wartości i formuły. Łącza do innych danych znajdujących się na tej samej stronie sieci Web oraz łącza do innych stron nie zostaną zachowane w programie Excel.
  • Po wyeksportowaniu niektórych formatów liczby arkusza kalkulacyjnego, dane są wyświetlane w programie Excel w niestandardowym formacie liczby. W niestandardowym formacie liczby są wyświetlane na przykład formaty arkusza kalkulacyjnego typu Tak/Nie, Prawda/Fałsz i Wł/Wył. Aby uzyskać informacje na temat niestandardowych formatów liczby, zapoznaj się z Pomocą programu Excel.


Rozwiązywanie problemów z arkuszami kalkulacyjnymi

Wprowadzanie i edytowanie danych i formuł

Nie mogę zmienić komórek w arkuszu kalkulacyjnym

Komórki mogą być zablokowane i chronione. Aby uzyskać więcej informacji, skontaktuj się z projektantem strony sieci Web.

Nie mogę zawinąć tekstu w komórkach arkusza kalkulacyjnego

Zawinięty tekst w komórkach jest nieobsługiwany w składniku Microsoft Office Spreadsheet Component (składniku arkusz kalkulacyjny). Aby poprawnie wyświetlić tekst, można skrócić go, użyć wielu komórek do umieszczenia tekstu lub poszerzyć kolumnę tak, aby wyświetlić cały tekst.

W arkuszu kalkulacyjnym nie ma paska formuły

W przeciwieństwie do programu Microsoft Excel składnik Microsoft Office Spreadsheet Component nie zapewnia paska formuły, w którym można edytować zawartość komórek. Można jednak edytować zawartość komórki, klikając ją dwukrotnie lub zaznaczając komórkę i naciskając klawisz F2.

Nie mogę zmienić hiperłącza

Podczas modyfikowania hiperłącza, które zostało opublikowane na podstawie arkusza kalkulacyjnego programu Microsoft Excel i utworzone oryginalnie za pomocą okna dialogowego Wstawianie hiperłącza programu Excel, można zmienić tekst wyświetlany jako hiperłącze, ale nie można zmienić adresu, do którego ono prowadzi. Aby zmienić adres, należy usunąć hiperłącze, a następnie wstawić ponownie nowe hiperłącze.

Nie mogę kontrolować rozmiaru arkusza kalkulacyjnego

Arkusz kalkulacyjny może być skonfigurowany do automatycznej zmiany rozmiaru. Aby uzyskać więcej informacji, skontaktuj się z projektantem strony sieci Web.

Nie mogę kontrolować wyświetlania lub ukrywania pasków przewijania w arkuszu kalkulacyjnym

Być może w arkuszu kalkulacyjnym ustawiona jest przez projektanta danej strony sieci Web automatyczna zmiana rozmiarów. Jeśli tak, to paski przewijania są wyświetlane wtedy, gdy arkusz kalkulacyjny osiąga największą ustawioną szerokość lub wysokość, bez względu, czy użytkownik ustawi wyświetlanie, czy ukrywanie pasków przewijania. Aby uzyskać więcej informacji, należy skontaktować się z projektantem danej sieci Web.

Filtrowanie, sortowanie i wyszukiwanie danych

Dane w arkuszu kalkulacyjnym są niepoprawnie sortowane

Jeżeli sortowanie arkusza kalkulacyjnego nie przynosi oczekiwanych wyników, należy sprawdzić następujące elementy:

Sprawdź zaznaczenie przed sortowaniem Po zaznaczeniu zakresu komórek do posortowania arkusz kalkulacyjny sortuje całą zawartość zakresu i tylko ten zakres. Oznacza to, że zaznaczony wiersz nagłówka również będzie sortowany. Oznacza to również, że po zaznaczeniu pojedynczej kolumny danych na liście przeznaczonej do posortowania sortowana będzie wyłącznie ta kolumna, a nie cała lista. Należy spróbować zaznaczyć pojedynczą komórkę w zakresie, który ma być posortowany, ale nie komórkę w wierszu nagłówka. Arkusz kalkulacyjny automatycznie wykryje dane do sortowania i wykluczy wiersz nagłówka. Jeśli powyższa metoda nie będzie działać prawidłowo w przypadku sortowanych danych, należy zaznaczyć cały zakres przeznaczony do posortowania, bez zaznaczania wiersza nagłówka.

Sprawdź, czy liczby są w formacie liczby Jeśli wartość nie jest posortowana we właściwej kolejności, to być może komórka została sformatowana jako tekst, a nie jako liczba. Na przykład w niektórych systemach księgowych podczas importowania danych do arkusza kalkulacyjnego liczby ujemne są konwertowane na tekst. Aby zastosować prawidłowe formatowanie, należy kliknąć komórkę, a następnie zmienić format liczby.

Sprawdź, czy daty i godziny są prawidłowo sformatowane Daty i godziny są traktowane jako liczby. Podczas wpisywania daty lub godziny format komórki zmienia się z ogólnego formatu liczb na wbudowany format daty lub czasu. Aby daty i godziny były sortowane prawidłowo, wszystkie daty i godziny w kolumnie muszą mieć taki sam format daty lub czasu. Aby zastosować prawidłowe formatowanie, należy kliknąć komórkę, a następnie zmienić format liczby.

Usuń wszystkie spacje wiodące Upewnij się, że dane nie są poprzedzone spacjami. Usuń wszystkie spacje wiodące przed rozpoczęciem sortowania danych .

Sprawdź ustawienia regionalne Kolejności sortowania różnią się w zależności od ustawień regionalnych. Upewnij się, że ustawienie regionalne w oknach Ustawienia regionalne lub Opcje regionalne w Panelu sterowania są prawidłowe. Aby uzyskać informacje dotyczące zmieniania ustawień regionalnych, zapoznaj się z Pomocą systemu Windows.

Upewnij się, że sortowanie kilku kolumn odbywa się w prawidłowej kolejności Jeśli sortowanych jest kilka kolumn, to kolejność sortowania określa sposób organizowania danych. Najpierw należy sortować kategorie niższego poziomu (wewnętrzne), a następnie kategorie wyższego poziomu (zewnętrzne).

Na liście w arkuszu kalkulacyjnym nie pojawiają się wszystkie dane

Być może lista została przefiltrowana za pomocą polecenia Autofiltr w celu wyświetlenia określonych wierszy. Jeśli z prawej strony górnej komórki każdej kolumny widoczna jest strzałka, wykonaj jedną z następujących czynności:

  • Kliknij strzałkę, a następnie kliknij opcję Pokaż wszystko.
  • Upewnij się, że na pasku narzędzi nie jest wciśnięty przycisk Autofiltr [image].

Nie mogę filtrować arkusza kalkulacyjnego, w którym są scalone komórki

Składnik Microsoft Office Spreadsheet Component (arkusz kalkulacyjny) nie obsługuje funkcji filtrowania list zawierających scalone komórki. Jeśli arkusz kalkulacyjny zawiera scalone komórki, to należy je rozdzielić, a następnie spróbować ponownie użyć polecenia Autofiltr.

Polecenie Znajdź następny nie powoduje odnalezienia danych w arkuszu kalkulacyjnym

Po zaznaczeniu zakresu danych polecenie Znajdź następny wyszukuje określone wartości tylko w zaznaczeniu. Aby znaleźć dane znajdujące się w dowolnym miejscu arkusza kalkulacyjnego, przed kliknięciem polecenia Znajdź następny należy zaznaczyć pojedynczą komórkę.

Po opublikowaniu arkusza kalkulacyjnego z programu Excel lista rozwijana Autofiltr zawiera błędy

W programie Microsoft Excel można utworzyć kryteria Autofiltru, których nie można wyświetlać na liście rozwijanej Autofiltr arkusza kalkulacyjnego. Na przykład w arkuszu kalkulacyjnym brakuje odpowiedników kryteriów „10 pierwszych...” lub „zaczyna się od”.

Podczas publikowania w programie Excel zakresu Autofiltru wykorzystującego kryteria, których nie można wyświetlić na liście Autofiltr, filtrowane elementy są poprawnie wyświetlane na stronie sieci Web, ale zawartość listy Autofiltr nie odzwierciedla wybranych kryteriów.

Listę rozwijaną można zresetować, klikając na pasku narzędzi arkusza kalkulacyjnego przycisk Autofiltr [image], aby wyłączyć filtr, a następnie ponowne klikając przycisk Autofiltr [image], aby włączyć filtr. Spowoduje to również zresetowanie wyświetlonej listy.

Importowanie i eksportowanie

Nie mogę opublikować za pomocą programu Microsoft Excel arkusza kalkulacyjnego, który jest chroniony hasłem

Za pomocą programu Microsoft Excel opublikować arkusz kalkulacyjny chroniony hasłem można tylko przy użyciu pustego hasła. Należy otworzyć oryginalny skoroszyt w programie Excel, usunąć hasło i ponownie spróbować opublikować arkusz kalkulacyjny.

Eksport filtru arkusza kalkulacyjnego do programu Excel nie przebiega poprawnie

W arkuszu kalkulacyjnym można utworzyć kryteria Autofiltru, których nie można wyświetlać na liście rozwijanej Autofiltr lub w oknie dialogowym Autofiltr niestandardowy programu Microsoft Excel. Na przykład w programie Excel brakuje bezpośredniego odpowiednika filtru arkusza kalkulacyjnego zawierającego trzy niezaznaczone elementy. Po eksportowaniu do programu Excel arkusza kalkulacyjnego zawierającego nieobsługiwane kryteria filtrowania w programie tym wyświetlany jest cały zakres Autofiltru.

Aby eksportować filtrowane dane i wyświetlić je tak samo, jak w arkuszu kalkulacyjnym, zalecane jest określenie dla każdego filtru nie więcej niż dwóch zestawów kryteriów; to jest należy mieć nie więcej niż dwa pola wyboru o różnych ustawieniach (zaznaczone lub wyczyszczone).

Gdy próbuję eksportować arkusz kalkulacyjny do programu Excel, otrzymuje komunikat, że wierszy lub kolumn jest zbyt wiele.

Arkusz kalkulacyjny może zawierać dane w kolumnach od A do ZZZ i wierszach od 1 do 262 144. W programie Microsoft Excel dane mogą zajmować tylko kolumny od A do IV i wiersze od 1 do 65 536. Aby eksportować arkusz kalkulacyjny do programu Excel, należy usunąć lub przenieść dane z kolumn dalszych niż IV i wierszy dalszych niż 65 536. Dodatkowe dane można skopiować do innego arkusza programu Excel.

Praca z arkuszem kalkulacyjnym w przeglądarce

Nie mogę pracować interaktywnie z arkuszem kalkulacyjnym

Jeśli możesz przeglądać, ale nie możesz pracować interaktywnie z arkuszem kalkulacyjnym, to być może nie masz dostępu do licencji pakietu Microsoft Office XP. Aby uzyskać więcej informacji, skontaktuj się z administratorem sieci.

Gdy otwieram w przeglądarce stronę sieci Web zawierającą arkusz kalkulacyjny, wyświetlany jest błąd „Nie można otworzyć adresu URL."

Strona sieci Web danych źródłowych jest niedostępna Jeśli niektóre dane w arkuszu kalkulacyjnym pochodzą z innej strony sieci Web, to należy się upewnić, czy strona sieci Web jest dostępna i masz do niej odpowiedni dostęp.

Strona sieci Web nie jest lokalna Jeśli arkusz kalkulacyjny zawiera formułę, która łączy do danych na innej stronie sieci Web, sprawdź, czy masz odpowiedni dostęp do strony sieci Web i czy strona ta Web znajduje się na komputerze lokalnym lub w sieci intranet. Aby uzyskać więcej informacji, skontaktuj się z administratorem sieci.

Kliknięcie przycisku Edytuj w przeglądarce sieci Web otwiera stronę sieci Web w niewłaściwym programie

Programy dostępne w przeglądarce sieci Web po kliknięciu przycisku Edytuj zależą do sposobu opublikowania strony.

Jeśli kliknięcie przycisku Edytuj w przeglądarce sieci Web otwiera niewłaściwy program, to należy go zamknąć, uruchomić żądany program, a następnie otworzyć w nim stronę sieci Web.

Wartości błędu

Zamiast wyników formuł widać wartości błędów

Jeśli nie można obliczyć części formuły lub wystąpił problem dotyczący formuły, formuła zwraca wartość błędu, taką jak #NAZWA? lub #DZIEL/0!. Aby określić przyczynę, należy zapoznać się z tematami dotyczącymi rozwiązywania problemów z wartościami błędów.


Rozwiązywanie problemów z wartościami błędów w arkuszu kalkulacyjnym

Jeśli formuła nie może prawidłowo obliczyć wyniku, arkusz kalkulacyjny wyświetla wartość błędu. Na przykład wartości błędów mogą być wyświetlane, jeśli formuła oczekuje wartości numerycznej, a odnajduje tekst, jeśli komórka, do której odwołuje się formuła, została usunięta albo komórka nie jest dostatecznie szeroka, aby wyświetlić wynik.

Nie zawsze przyczyną generowania wartości błędów są same formuły. Na przykład jeśli formuła pokazuje wartość #N/D lub #ARG!, to komórka, do której odwołuje się dana formuła, może zawierać błąd.

Poniżej przedstawiono listę możliwych przyczyn generowania wartości błędów i stosowanych rozwiązań:

#####

Wartość błędu ##### pojawia się, jeśli komórka zawiera liczbę, datę lub godzinę dłuższą niż szerokość komórki. Można zmienić rozmiar kolumny, przeciągając granicę między nagłówkami kolumn.

#CYKL!

Wartość błędu #CYKL! pojawia się, jeśli formuła bezpośrednio lub pośrednio odwołuje się do siebie samej.

Możliwa przyczyna | Sugerowana czynność
Formuła w komórce odwołuje się do siebie samej bezpośrednio. Na przykład komórka B10 zawiera formułę =SUMA(B5:B10). | Należy sprawdzić odwołania w formule i upewnić się, że odwołania nie dotyczą tej samej komórki.
Formuła w komórce odwołuje się do siebie samej pośrednio. Na przykład komórka B10 zawiera formułę =SUMA(B5:B9), a komórka B5 zawiera formułę =B10*0,5. | Należy sprawdzić wszystkie komórki, do których odwołuje się formuła i upewnić się, że żadna z nich nie zawiera odwołania do komórki, w której wyświetlany jest błąd #CYKL!. Jeśli którakolwiek z komórek, do których odwołuje się formuła, zawiera formuły, należy się upewnić, że komórki, do których się one odwołują, nie zawierają odwołań do komórki, w której wyświetlany jest błąd #CYKL!.

#DZIEL/0!

Wartość błędu #DZIEL/0! pojawia się, jeśli formuła wykonała próbę dzielenia przez 0 (zero).

Możliwa przyczyna | Sugerowana czynność
Użyto dzielnika odwołującego się do pustej komórki lub komórki zawierającej 0. (Jeśli operand odwołuje się do komórki pustej, to jego wartość jest interpretowana jako 0.) | Należy zmienić odwołanie do komórki lub wprowadzić wartość inną niż 0 w komórce używanej jako dzielnik. W komórce służącej jako dzielnik można wprowadzić wartość #N/D, co spowoduje zmianę wyniku formuły na wartość #N/D oznaczającą, że wartość dzielnika jest niedostępna. Aby zapobiec wyświetlaniu wartości błędu, należy użyć funkcji arkusza kalkulacyjnego JEŻELI. Jeśli dzielnik odwołuje się do komórki pustej lub zawierającej 0, funkcja JEŻELI umożliwia wyświetlenie ciągu pustego zamiast wartości błędu. Można na przykład użyć zapisu =JEŻELI(B5=0;"";A5/B5). Dwa znaki cudzysłowu reprezentują pusty ciąg tekstowy.
Użycie 0 jako dzielnika — na przykład, =5/0. | Należy zmienić dzielnik na liczbę różną od 0.

#N/D

Wartość błędu #N/D pokazuje się, jeśli wartość jest niedostępna dla funkcji lub formuły.

Jeśli określone komórki arkusza kalkulacyjnego będą zawierać dane, które nie są jeszcze dostępne, to można wprowadzić w nich wartość #N/D, aby odwołujące się do nich formuły zwracały wartość #N/D, nie próbując obliczać wartości.

Jeśli potrzebne wartości są dostępne, a wartość błędu #N/D jest nadal wyświetlana, choć powinno jej nie być, to być może przyczyną są specyficzne wymagania funkcji dotyczące argumentów, które nie zostały spełnione lub nieprawidłowe odwołania do wartości w formule lub argumentach funkcji.

Możliwa przyczyna | Sugerowana czynność
Podanie nieodpowiedniej wartości jako argumentu szukana_wartość funkcji arkusza kalkulacyjnego WYSZUKAJ.POZIOMO, WYSZUKAJ, PODAJ.POZYCJĘ, lub WYSZUKAJ.PIONOWO. | Należy się upewnić, że argument szukana_wartość ma poprawny typ wartości, na przykład wartość lub odwołanie do komórki, ale nie odwołanie do zakresu.
Użycie funkcji arkusza kalkulacyjnego PODAJ.POZYCJĘ z nieodpowiednim argumentem typ_porównania. | Funkcja arkusza kalkulacyjnego PODAJ.POZYCJĘ zawiera argument typ_porównania określający sposób porównywania przez funkcję argumentu szukana_wartość z wartościami argumentu przeszukiwana_tab. Na przykład argument typ_porównania może być tak ustawiony, aby wartość zbliżona lub identyczna była poszukiwana w argumencie przeszukiwana_tab posortowanym w porządku rosnącym lub malejącym lub w nieposortowanym. Jeśli funkcja nie może odnaleźć odpowiednika, należy się upewnić, że argument przeszukiwana_tab jest posortowany zgodnie z użytym argumentem typ_porównania i/lub spróbować zmienić argument typ_porównania.
Użycie funkcji arkusza kalkulacyjnego WYSZUKAJ.POZIOMO lub WYSZUKAJ.PIONOWO z argumentem przeszukiwany_zakres ustawionym na wartość FAŁSZ w celu lokalizowania niedostępnej wartości. | Funkcje arkusza kalkulacyjnego WYSZUKAJ.PIONOWO lub WYSZUKAJ.POZIOMO zawierają argument przeszukiwany_zakres, który nakazuje funkcji odnalezienie dokładnego lub przybliżonego odpowiednika. Jeśli argument ma wartość PRAWDA lub jest pominięty, zwracany jest odpowiednik przybliżony. Innymi słowy, jeśli nie zostanie odnaleziony dokładny odpowiednik, zwracana jest największa kolejna wartość mniejsza od wartości argumentu szukana_wartość. Jeśli argument ma wartość FAŁSZ, funkcja WYSZUKAJ.PIONOWO znajdzie dokładny odpowiednik. Jeśli dokładny odpowiednik nie zostanie odnaleziony, to zwracana jest wartość błędu #N/D. Należy się upewnić, że szukana wartość znajduje się w argumencie przeszukiwana_tab.
Pominięcie jednego lub kilku argumentów w funkcji arkusza kalkulacyjnego. | Należy podać wszystkie wymagane argumenty w funkcji.

#NAZWA?

Wartość błędu #NAZWA? pojawia się, jeśli nie został rozpoznany tekst znajdujący się w formule.

Możliwa przyczyna | Sugerowana czynność
Błąd w pisowni nazwy funkcji. | Należy poprawić pisownię.
Wprowadzenie tekstu w formule bez ujęcia go w podwójny cudzysłów. Wpis tego typu nie jest prawidłowo interpretowany jako tekst. | Należy ująć tekst w formule w podwójny cudzysłów. Na przykład poniższa formuła łączy fragment tekstu „Całkowita suma wynosi ” z wartością w komórce B50: ="Całkowita suma wynosi "&B50
Pominięcie dwukropka (:) w odwołaniu do zakresu. | Należy się upewnić, że we wszystkich odwołaniach do zakresu w formule użyto dwukropka (:). Na przykład =SUMA(A1:C10).

#ZERO!

Wartość błędu #ZERO! pojawia się, jeśli zdefiniowano część wspólną dwóch obszarów, które w rzeczywistości się nie przecinają.

Możliwa przyczyna | Sugerowana czynność
Użycie nieprawidłowego operatora zakresu. | Aby odwołać się do dwóch obszarów, które się nie przecinają, należy użyć operatora połączenia, którym jest przecinek (,). Na przykład formuła =SUMA(A1:A10;C1:C10) podsumowująca dwa zakresy, które się nie przecinają, zawiera przecinek oddzielający oba zakresy. Aby odwołać się do dwóch przecinających się obszarów, należy użyć operatora części wspólnej, którym jest pojedyncza spacja. Na przykład formuła =SUMA(B5:C15 A10:D10) oblicza sumę wartości komórek wspólnych dla obu zakresów, tzn. znajdujących się w punkcie przecięcia zakresów B10 i C10.
Użycie nieprawidłowego odwołania do komórki. | Należy sprawdzić, czy w odwołaniach do zakresów nie ma błędów.

#LICZBA!

Wartość błędu #LICZBA! pojawia się, jeśli wystąpi problem związany z liczbą w formule lub funkcji.

Możliwa przyczyna | Sugerowana czynność
Użycie nieodpowiedniego argumentu w funkcji wymagającej argumentu numerycznego. | Należy się upewnić, że w funkcji użyto argumentów właściwego typu.
Użycie funkcji arkusza kalkulacyjnego wykonującej obliczenia iteracyjne, takiej jak IRR lub RATE, jeśli po określonej liczbie prób funkcja nie może odnaleźć wyniku o dokładności w określonym procentowym zakresie tolerancji. | Należy spróbować użyć innych wartości jako argumentu docelowego.
Efektem działania formuły jest liczba zbyt duża lub zbyt mała, aby mogła być reprezentowana w arkuszu kalkulacyjnym. | Wartości w arkuszu kalkulacyjnym muszą zawierać się w zakresie od Minus 1 razy 10 do potęgi 307 do 1 razy 10 do potęgi 307 .

#ADR!

Wartość błędu #ADR! pojawia się, jeśli odwołanie do komórki jest nieprawidłowe.

Możliwa przyczyna | Sugerowana czynność
Usunięcie komórek, do których odwołują się inne formuły lub wklejenie przeniesionych komórek, do których odwołują się inne formuły. | Należy skorygować formuły lub przywrócić komórki w arkuszu kalkulacyjnym, klikając przycisk Cofnij [image] natychmiast po usunięciu lub wklejeniu komórek.

#ARG!

Wartość błędu #ARG! pojawia się, jeśli użyto nieprawidłowego typu argumentu lub operandu.

Możliwa przyczyna | Sugerowana czynność
Wprowadzenie tekstu w formule, która wymaga wartości liczbowej lub logicznej, takiej jak PRAWDA lub FAŁSZ. Tekst nie może być przekształcony na prawidłowy typ danych. | Należy się upewnić, że wartość operandu lub argumentu to odpowiedni typ danych dla formuły lub funkcji, a komórki, do których odwołuje się formuła, zawierają prawidłowe wartości. Na przykład jeśli komórka A5 zawiera liczbę, a komórka A6 tekst „Niedostępna”, to formuła =A5+A6 zwróci wartość błędu #ARG!. Aby dodać te dwie wartości, należy w formule użyć funkcji arkusza kalkulacyjnego SUMA w następujący sposób (funkcja SUMA ignoruje tekst): =SUMA(A5:A6)
Podanie zakresu dla operatora lub funkcji, która wymaga pojedynczej wartości. | Należy zmienić zakres na pojedynczą wartość.
Pominięcie zakresu, gdy jest on wymagany przez funkcję. | Niektóre funkcje, takie jak LICZ.JEŻELI i SUMA.JEŻELI, wymagają podania zakresu. Należy się upewnić, że podano wszystkie zakresy wymaganych argumentów.
Podanie wartości innej niż 1 dla argumentu A1 funkcji arkusza kalkulacyjnego ADRES. | Funkcja ADRES może zwracać tylko odwołania typu A1. Należy zmienić wartość argumentu na 1.
Użycie obliczanych kryteriów — warunkiem jest formuła — dla funkcji baz danych (funkcje D). | Funkcje baz danych dostępne w składniku Arkusz kalkulacyjny nie obsługują obliczanych kryteriów (na przykład "=Pole1<Pole2"). Należy zmienić kryteria na proste warunki, takie jak „Pole1”.
Odwołanie do wielu zakresów za pomocą funkcji arkusza kalkulacyjnego OBSZARY. | Funkcja arkusza kalkulacyjnego OBSZARY nie obsługuje wielu zakresów. Należy utworzyć odwołanie tylko do pojedynczego zakresu komórek.